# Error: Unprocessable Entity

**URL:** <https://community.forestadmin.com/t/error-unprocessable-entity/364>\
**Category:** Help me!\
**Created:** [May 30, 2020, 1:33pm UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364 "2020-05-30T13:33:13Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![John](https://dub1.discourse-cdn.com/flex013/user_avatar/community.forestadmin.com/john/32/272_2.png) [@John](https://community.forestadmin.com/u/John)\
**Post date:** [May 30, 2020, 1:33pm UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/1 "2020-05-30T13:33:13Z")

</div>

Hello. I’m trying to deploy lumber-admin via Docker with remote database. And I getting an error:

> Error: Unprocessable Entity

I’m using next command:

```javascript
sudo docker run \
  -v `pwd`:/usr/src/app --init \
  -e DATABASE_SCHEMA="public" \
  -e DATABASE_SSL="false" \
  -e DATABASE_URL="postgres://postgres:123456@[ip]:5432/cleanandgreen" \
  -e APP_NAME="jopas_remote" \
  -e FOREST_EMAIL="[email]" \
  -e FOREST_TOKEN="[token]" \
  -e APPLICATION_HOST="[ip]" \
  -e APPLICATION_PORT="3310" \
  -ti forestadmin/lumber

```

I suspect problem on DB, but I cannot find any details or logs about this event. So, my main question is: where I can find any logs? Thx

 ![2020-05-30 16_36_20-ApiCleanandGreen C__xampp_php7.2_htdocs_dmitriig_ApiCleanandGreen - ..._.notes](https://europe1.discourse-cdn.com/flex013/uploads/forest/original/1X/eb5ec9fac800f1d495ebd732c3b60cd050d7d4cf.png)

---

<div class="post-metadata">

**Author:** ![anon94532230](https://avatars.discourse-cdn.com/v4/letter/a/a587f6/32.png) [@anon94532230](https://community.forestadmin.com/u/anon94532230)\
**Post date:** [June 1, 2020, 8:29am UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/2 "2020-06-01T08:29:33Z")

</div>

Hi @John ! Welcome to the community 🙂

Which version of lumber are you using ?  
Can you connect to your database using this link (with postgres cli) ?

---

<div class="post-metadata">

**Author:** ![anon94532230](https://avatars.discourse-cdn.com/v4/letter/a/a587f6/32.png) [@anon94532230](https://community.forestadmin.com/u/anon94532230)\
**Post date:** [June 1, 2020, 10:21am UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/4 "2020-06-01T10:21:19Z")

</div>

I took the liberty to anonymise your post, be careful not to share sensitive information on public forums 😉  
Give me some time to look at your problem and get back to you !

---

<div class="post-metadata">

**Author:** ![anon94532230](https://avatars.discourse-cdn.com/v4/letter/a/a587f6/32.png) [@anon94532230](https://community.forestadmin.com/u/anon94532230)\
**Post date:** [June 1, 2020, 10:29am UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/5 "2020-06-01T10:29:44Z")

</div>

Ok it seems to be because your endpoint (APPLICATION\_HOST) is not set as https, see [this](https://docs.forestadmin.com/documentation/how-tos/setup/install-forest-admin-on-a-remote-machine#using-docker) part of the documentation to read about setting up forest on a remote environment with docker @John 🙂

---

<div class="post-metadata">

**Author:** ![John](https://dub1.discourse-cdn.com/flex013/user_avatar/community.forestadmin.com/john/32/272_2.png) [@John](https://community.forestadmin.com/u/John)\
**Post date:** [June 1, 2020, 10:35am UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/6 "2020-06-01T10:35:13Z")

</div>

Do I need to enable ssl on DB?

---

<div class="post-metadata">

**Author:** ![anon94532230](https://avatars.discourse-cdn.com/v4/letter/a/a587f6/32.png) [@anon94532230](https://community.forestadmin.com/u/anon94532230)\
**Post date:** [June 1, 2020, 10:36am UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/7 "2020-06-01T10:36:30Z")

</div>

You need to enable SSL on your remote server so that the requests to the app can be done through https

---

<div class="post-metadata">

**Author:** ![John](https://dub1.discourse-cdn.com/flex013/user_avatar/community.forestadmin.com/john/32/272_2.png) [@John](https://community.forestadmin.com/u/John)\
**Post date:** [June 1, 2020, 10:43am UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/8 "2020-06-01T10:43:40Z")

</div>

Thx. Now I’m using next command for deploying Forest Admin. How I can install my ssl cert?

```javascript
    lumber generate "${APPLICATION_NAME:-$APP_NAME}" \
        -c "${DATABASE_URL}" \
        -S "${DATABASE_SSL:-false}" \
        -s "${DATABASE_SCHEMA}" \
        -H "${APPLICATION_HOST}" \
        -p "${APPLICATION_PORT}" \
    cd "${APPLICATION_NAME:-$APP_NAME}" && \
    npm install lumber-forestadmin -s --save && \
    lumber install lumber-forestadmin \
        --email "${FOREST_EMAIL}" \
        --password "${FOREST_PASSWORD}" \
        --projectName "${APPLICATION_NAME:-$APP_NAME}" && \
    npm install -s && \
    npm start

```

Unfortunately I can’t find any info about SSL-cert installation regarding vanila examples.

---

<div class="post-metadata">

**Author:** ![anon94532230](https://avatars.discourse-cdn.com/v4/letter/a/a587f6/32.png) [@anon94532230](https://community.forestadmin.com/u/anon94532230)\
**Post date:** [June 1, 2020, 1:21pm UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/9 "2020-06-01T13:21:30Z")

</div>

The ssl needs to be enabled on your server, redirect the traffic through the port 443 with ssl enabled.  
Do you still have the same error after enabling ssl on your server ?

---

<div class="post-metadata">

**Author:** ![John](https://dub1.discourse-cdn.com/flex013/user_avatar/community.forestadmin.com/john/32/272_2.png) [@John](https://community.forestadmin.com/u/John)\
**Post date:** [June 1, 2020, 2:48pm UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/10 "2020-06-01T14:48:21Z")

</div>

Are you talking about Forest Admin Backend Server? lumber-forestadmin relies on Node Server. I haven’t another servers. I’m looking for opportunity to set ssl certificates via lumber-cli.

---

<div class="post-metadata">

**Author:** ![anon94532230](https://avatars.discourse-cdn.com/v4/letter/a/a587f6/32.png) [@anon94532230](https://community.forestadmin.com/u/anon94532230)\
**Post date:** [June 1, 2020, 3:11pm UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/11 "2020-06-01T15:11:29Z")

</div>

No, I am talking about the server on which you are trying to run your lumber project, at the operating system level.

---

<div class="post-metadata">

**Author:** ![John](https://dub1.discourse-cdn.com/flex013/user_avatar/community.forestadmin.com/john/32/272_2.png) [@John](https://community.forestadmin.com/u/John)\
**Post date:** [June 1, 2020, 3:14pm UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/12 "2020-06-01T15:14:46Z")

</div>

And how this help Forest to communicate with my-hosted backend via https? And how I can install some certs at the operating system level?

---

<div class="post-metadata">

**Author:** ![anon94532230](https://avatars.discourse-cdn.com/v4/letter/a/a587f6/32.png) [@anon94532230](https://community.forestadmin.com/u/anon94532230)\
**Post date:** [June 1, 2020, 3:20pm UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/13 "2020-06-01T15:20:10Z")

</div>

Forest’s frontend require your lumber project to be accessible via https, the lumber project is connected to your database (which is on the same server from what I see, so no need for ssl here) and it is not connected to your own backend.  
What FA does is generate a backend to connect with FA’s frontend which give you an admin panel that you can customize following your needs. 🙂

---

<div class="post-metadata">

**Author:** ![John](https://dub1.discourse-cdn.com/flex013/user_avatar/community.forestadmin.com/john/32/272_2.png) [@John](https://community.forestadmin.com/u/John)\
**Post date:** [June 1, 2020, 3:23pm UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/14 "2020-06-01T15:23:26Z")

</div>

> [@anon94532230](#):
>
> What FA does is generate a backend to connect with FA’s frontend which give you an admin panel that you can customize following your needs.

Right, lumber-cli does generate backend, which based on Node’s web-server on 80 port, and Forest cannot establish connection with https protocol of this web-server because your Node’s app.js haven’t configured any SSL to fit this requirement.

And now I see I need to deploy my own server to install SSL-certs for Forest Backend, or I need to make modifications in app.js. But I don’t see how I can just install certs without this dances to Node’s web-server.

---

<div class="post-metadata">

**Author:** ![anon94532230](https://avatars.discourse-cdn.com/v4/letter/a/a587f6/32.png) [@anon94532230](https://community.forestadmin.com/u/anon94532230)\
**Post date:** [June 1, 2020, 3:27pm UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/15 "2020-06-01T15:27:34Z")

</div>

Node.js doesn’t necessary need an https configuration, you can use a reverse proxy to route the request through https.  
For exemple you can look at this [thread](https://stackoverflow.com/a/46454504/7996564).

---

<div class="post-metadata">

**Author:** ![John](https://dub1.discourse-cdn.com/flex013/user_avatar/community.forestadmin.com/john/32/272_2.png) [@John](https://community.forestadmin.com/u/John)\
**Post date:** [June 1, 2020, 3:28pm UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/16 "2020-06-01T15:28:08Z")

</div>

So, finally I need my own web-server deployed?

---

<div class="post-metadata">

**Author:** ![anon94532230](https://avatars.discourse-cdn.com/v4/letter/a/a587f6/32.png) [@anon94532230](https://community.forestadmin.com/u/anon94532230)\
**Post date:** [June 1, 2020, 3:29pm UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/17 "2020-06-01T15:29:02Z")

</div>

Well if you are trying to deploy it on a remote server (where you database is) you already have it, you just need to configure it to have ssl 🙂

---

<div class="post-metadata">

**Author:** ![John](https://dub1.discourse-cdn.com/flex013/user_avatar/community.forestadmin.com/john/32/272_2.png) [@John](https://community.forestadmin.com/u/John)\
**Post date:** [June 1, 2020, 3:29pm UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/18 "2020-06-01T15:29:44Z")

</div>

I am ready to deploy it locally, but I do not understand how to use Forest Frontend in this case. Frontend need public-hosted backend to access. All of my services deployed locally and all the troubles because Forest Frontend cannot work without cloud

---

<div class="post-metadata">

**Author:** ![anon94532230](https://avatars.discourse-cdn.com/v4/letter/a/a587f6/32.png) [@anon94532230](https://community.forestadmin.com/u/anon94532230)\
**Post date:** [June 1, 2020, 3:37pm UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/19 "2020-06-01T15:37:31Z")

</div>

I’ll try to be more clear 🙂  
FA’s goal is to allow you to quickly setup an admin panel, to this end we scan your db and we generate a lumber project for you.  
The error you are getting appears when you try to generate your lumber project.  
We advise to first generate a `development` environment locally and then deploy it to a remote server for your `production` environment.  
Remote environments needs to work through https to enforce security.  
Local environment doesn’t need to since they run on your machine and you are accessing our frontend directly on this machine (the request are done on localhost).

Forest frontend is just the interface with whom your generated project communicates.  
The lumber project is the “bridge” between forest and your database, where you put your logic.  
Your own app (back and front) are not connected to FA, only your database.

Don’t hesitate if I explained badly 😅 I advise you to read the doc, it’s explained more clearly than what I can do here.

---

<div class="post-metadata">

**Author:** ![John](https://dub1.discourse-cdn.com/flex013/user_avatar/community.forestadmin.com/john/32/272_2.png) [@John](https://community.forestadmin.com/u/John)\
**Post date:** [June 1, 2020, 3:42pm UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/20 "2020-06-01T15:42:47Z")

</div>

> [@anon94532230](#):
>
> Local environment doesn’t need to since they run on your machine and you are accessing our frontend directly on this machine (the request are done on localhost).

How I can directly access Forest Frontend - locally, without remotes? I could not find any way but Frontend on Forest servers. I don’t know how to use Forest without your servers.

---

<div class="post-metadata">

**Author:** ![anon36130554](https://avatars.discourse-cdn.com/v4/letter/a/b3f665/32.png) [@anon36130554](https://community.forestadmin.com/u/anon36130554)\
**Post date:** [June 1, 2020, 4:30pm UTC](https://community.forestadmin.com/t/error-unprocessable-entity/364/21 "2020-06-01T16:30:21Z")

</div>

Hello @John 👋 welcome again to our community 🙌

Let’s sum up what have been said there.

In this message, I’ll assume that you are deploying to a remote (I’ve seen that you already own two development environments, and that one remote environment is awaiting to be configured).

The docker command you are trying to run is used to generate an entire code base **localy** , which you already did. So there, you are trying to re-create an additional code base which is not what you want.

If you want to deploy to a remote, you just have to follow the wizard steps by going to your project settings --\> environment --\> deploy button --\> `deploy to a remote first`

You will see that no docker command is needed. This is because we recommend to version the generated code you’ve got from the first docker command you ran, then `deploy` it (upload it) to your remote instance.

From there, you will need to edit your environment variables (in the `.env` file) as your DB endpoint might have changed for example. And additionally, you will need to activate SSL in your remote instance for security reasons. The SSL has nothing to do with Forest, Lumber or either the DB. It has to be configured on your remote machine to establish a secure connexion between forest UI and you project (if you can give us your provider name, we might help with some documentation on how to do that).

If I misunderstood your problem at some point, please correct me and we will iterate 👍

I wish you a good evening,

Steve.

[Next page](https://community.forestadmin.com/t/error-unprocessable-entity/364.md?page=2)
