# Forest "Request Entity Too Large" error when updating .forestadmin-schema.json

**URL:** https://community.forestadmin.com/t/forest-request-entity-too-large-error-when-updating-forestadmin-schema-json/8332
**Category:** Help me!
**Created:** [October 17, 2025, 8:55am UTC](https://community.forestadmin.com/t/forest-request-entity-too-large-error-when-updating-forestadmin-schema-json/8332 "2025-10-17T08:55:09Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Matthieu\_Delanoe](https://dub1.discourse-cdn.com/flex013/user_avatar/community.forestadmin.com/matthieu_delanoe/32/8060_2.png) [@Matthieu\_Delanoe](https://community.forestadmin.com/u/Matthieu_Delanoe)
#### Post date: [October 17, 2025, 8:55am UTC](https://community.forestadmin.com/t/forest-request-entity-too-large-error-when-updating-forestadmin-schema-json/8332/1 "2025-10-17T08:55:10Z")

</div>

## Feature(s) impacted

Update of models schema on Forest

## Observed behavior

When deploying a new version of our Forest agent, synchronization of .forestadmin-schema.json file fails with Forest servers with error “413 Request Entity Too Large”. Error started to ocurre less than a week ago, and sometimes after a few retries it ends up working, but not always.  
File is about 1.6Mo.  
Seems like a Forest server file upload limit or something..

## Expected behavior

When the .forestadmin-schema.json is regerated or when the Forest agent starts, it should send it to Forest server for sync, and it should succeed

## Failure Logs

```javascript
 "header": {
     "date": "Fri, 17 Oct 2025 08:19:31 GMT",
     "content-type": "text/html",
     "content-length": "183",
     "connection": "close",
     "server": "nginx/1.28.0"
   },
   "status": 413,
   "text": "<html>\r\n<head><title>413 Request Entity Too Large</title></head>\r\n<body>\r\n<center><h1>413 Request Entity Too Large</h1></center>\r\n<hr><center>nginx/1.28.0</center>\r\n</body>\r\n</html>\r\n"

```

## Context

- Project name: AirSaas
- Team name: Operations
- Environment name: Review App - PFS dashboard
- Database type: Postgres
- Recent changes made on your end if any: addition of new fields/tables, which we do very often, nothing out of the ordinary

**And, if you are self-hosting your agent:**

- Agent technology: node
- Agent (forest package) name & version (from your .lock file): forest-express-sequelize 9.6.1 ; forest-express 10.6.7

```javascript
"meta": {
         "liana": "forest-express-sequelize",
         "liana_version": "9.6.1",
         "stack": {
           "database_type": "postgres",
           "engine": "nodejs",
           "engine_version": "20.19.5",
           "orm_version": "6.37.3"
         },
         "schemaFileHash": "e5fda648d55844097c6170d7a9678419c2bd5821"
       }

```

---

<div class="post-metadata">

### Author: ![Nicolas\_Moreau](https://dub1.discourse-cdn.com/flex013/user_avatar/community.forestadmin.com/nicolas_moreau/32/8061_2.png) [@Nicolas\_Moreau](https://community.forestadmin.com/u/Nicolas_Moreau)
#### Post date: [October 17, 2025, 10:41am UTC](https://community.forestadmin.com/t/forest-request-entity-too-large-error-when-updating-forestadmin-schema-json/8332/2 "2025-10-17T10:41:26Z")

</div>

Hi lumberjacks !  
I’m throwing a `me too` here.  
We have multiple developers impacted by this issue on our side 😕

Thanks for having a quick look ! 🙏

```javascript
  error: Error: cannot POST /forest/apimaps (413)
      at Response.toError (/Users/nicolas.moreau/*/back-office-api-gitlab/node_modules/@forestadmin/forestadmin-client/node_modules/superagent/src/node/response.js:110:17)
      at Response._setStatusProperties (/Users/nicolas.moreau/*/back-office-api-gitlab/node_modules/@forestadmin/forestadmin-client/node_modules/superagent/src/response-base.js:107:48)
      at new Response (/Users/nicolas.moreau/*/back-office-api-gitlab/node_modules/@forestadmin/forestadmin-client/node_modules/superagent/src/node/response.js:41:8)
      at Request._emitResponse (/Users/nicolas.moreau/*/back-office-api-gitlab/node_modules/@forestadmin/forestadmin-client/node_modules/superagent/src/node/index.js:932:20)
      at IncomingMessage.<anonymous> (/Users/nicolas.moreau/*/back-office-api-gitlab/node_modules/@forestadmin/forestadmin-client/node_modules/superagent/src/node/index.js:1170:38)
      at /Users/nicolas.moreau/*/back-office-api-gitlab/node_modules/@opentelemetry/context-async-hooks/src/AbstractAsyncHooksContextManager.ts:75:49
      at AsyncLocalStorage.run (node:async_hooks:335:14)
      at AsyncLocalStorageContextManager.with (/Users/nicolas.moreau/*/back-office-api-gitlab/node_modules/@opentelemetry/context-async-hooks/src/AsyncLocalStorageContextManager.ts:40:36)
      at IncomingMessage.contextWrapper (/Users/nicolas.moreau/*/back-office-api-gitlab/node_modules/@opentelemetry/context-async-hooks/src/AbstractAsyncHooksContextManager.ts:75:26)
      at IncomingMessage.emit (node:events:531:35)
      at IncomingMessage.emit (node:domain:488:12)
      at endReadableNT (node:internal/streams/readable:1696:12)
      at processTicksAndRejections (node:internal/process/task_queues:82:21) {
    status: 413,
    text: '<html>\r\n' +
      '<head><title>413 Request Entity Too Large</title></head>\r\n' +
      '<body>\r\n' +
      '<center><h1>413 Request Entity Too Large</h1></center>\r\n' +
      '<hr><center>nginx/1.28.0</center>\r\n' +
      '</body>\r\n' +
      '</html>\r\n',
    method: 'POST',
    path: '/forest/apimaps'
  },

```

---

<div class="post-metadata">

### Author: ![anon7284711](https://avatars.discourse-cdn.com/v4/letter/a/ac8455/32.png) [@anon7284711](https://community.forestadmin.com/u/anon7284711)
#### Post date: [October 17, 2025, 1:08pm UTC](https://community.forestadmin.com/t/forest-request-entity-too-large-error-when-updating-forestadmin-schema-json/8332/3 "2025-10-17T13:08:19Z")

</div>

Hello @Matthieu_Delanoe and @Nicolas_Moreau,

Sorry for the late reply, we’ve been working on this nonetheless.  
This issue as reported is linked to a limitation on payload size to request forwarded to our server.

We were able to rollback to the previous infra, we are already seeing some users successfully posting their schema.

Please try again, if you’re still experiencing the issue maybe clearing the DNS resolution cache might help.

Keep us updated if you’re still stuck,

Sorry for the inconvenience,

Best regards,

---

<div class="post-metadata">

### Author: ![Matthieu\_Delanoe](https://dub1.discourse-cdn.com/flex013/user_avatar/community.forestadmin.com/matthieu_delanoe/32/8060_2.png) [@Matthieu\_Delanoe](https://community.forestadmin.com/u/Matthieu_Delanoe)
#### Post date: [October 21, 2025, 6:36pm UTC](https://community.forestadmin.com/t/forest-request-entity-too-large-error-when-updating-forestadmin-schema-json/8332/4 "2025-10-21T18:36:39Z")

</div>

It seems ok on my side now, thx for the reactivity!
