# "Unable to authenticate you"

**URL:** <https://community.forestadmin.com/t/unable-to-authenticate-you/3614>\
**Category:** Help me!\
**Created:** [October 26, 2021, 10:02am UTC](https://community.forestadmin.com/t/unable-to-authenticate-you/3614 "2021-10-26T10:02:47Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Raphael](https://avatars.discourse-cdn.com/v4/letter/r/edb3f5/32.png) [@Raphael](https://community.forestadmin.com/u/Raphael)\
**Post date:** [October 26, 2021, 10:02am UTC](https://community.forestadmin.com/t/unable-to-authenticate-you/3614/1 "2021-10-26T10:02:47Z")

</div>

Hi, I’m reaching out because I’m having trouble connecting my Rails app to Forest Admin. I’ve gone through the whole process with success and am able to access ForestAdmin in Development but when I try to switch to Production environment, I get an error message saying “Please verify that your admin backend is correctly configured and running, and that you have access to the internet.” I’ve checked that my API keys are correct in Production. I have no idea what is going wrong and how I can solve it.  
Has anyone encountered this issue before ? Thanks !

---

<div class="post-metadata">

**Author:** ![anon39848301](https://avatars.discourse-cdn.com/v4/letter/a/b9e5f3/32.png) [@anon39848301](https://community.forestadmin.com/u/anon39848301)\
**Post date:** [October 26, 2021, 10:14am UTC](https://community.forestadmin.com/t/unable-to-authenticate-you/3614/2 "2021-10-26T10:14:05Z")

</div>

Hey @Raphael, and welcome to our community

Could you share your project name so I can check your configuration on my end?  
Is your project recent? Maybe you are impacted by [this issue](https://community.forestadmin.com/t/forest-down-ssl-issue-trouble-logging-in-error-400-invalid-client-id/3376)?

Let me know if it help 🙏

---

<div class="post-metadata">

**Author:** ![Raphael](https://avatars.discourse-cdn.com/v4/letter/r/edb3f5/32.png) [@Raphael](https://community.forestadmin.com/u/Raphael)\
**Post date:** [October 26, 2021, 10:23am UTC](https://community.forestadmin.com/t/unable-to-authenticate-you/3614/3 "2021-10-26T10:23:46Z")

</div>

Hey @anon39848301, thanks for responding! My project’s name is Lighthouse-Music. I’m looking into the link you sent me but getting nowhere so far

---

<div class="post-metadata">

**Author:** ![anon39848301](https://avatars.discourse-cdn.com/v4/letter/a/b9e5f3/32.png) [@anon39848301](https://community.forestadmin.com/u/anon39848301)\
**Post date:** [October 26, 2021, 10:26am UTC](https://community.forestadmin.com/t/unable-to-authenticate-you/3614/4 "2021-10-26T10:26:14Z")

</div>

If you can, it could also help to have a screenshot of the network console on the call that is failing to authenticate (Both request & response).

---

<div class="post-metadata">

**Author:** ![Raphael](https://avatars.discourse-cdn.com/v4/letter/r/edb3f5/32.png) [@Raphael](https://community.forestadmin.com/u/Raphael)\
**Post date:** [October 26, 2021, 10:30am UTC](https://community.forestadmin.com/t/unable-to-authenticate-you/3614/5 "2021-10-26T10:30:50Z")

</div>

![Capture d’écran 2021-10-26 à 12.29.04](https://europe1.discourse-cdn.com/flex013/uploads/forest/original/2X/9/9e322aa939937637a9328b89813c54a0a913fa87.png)  
 ![Capture d’écran 2021-10-26 à 12.28.59](https://europe1.discourse-cdn.com/flex013/uploads/forest/original/2X/b/b74838df5da3b70615305a190e33a27e0b53083a.png)

Here are the network console screen shots. I have now found that the problem comes from the SSL certificat and followed this article ([Trouble logging in | ForestAdmin](https://status.forestadmin.com/incident/55494)) to try and resolve it, however I still get the error…

---

<div class="post-metadata">

**Author:** ![anon39848301](https://avatars.discourse-cdn.com/v4/letter/a/b9e5f3/32.png) [@anon39848301](https://community.forestadmin.com/u/anon39848301)\
**Post date:** [October 26, 2021, 10:37am UTC](https://community.forestadmin.com/t/unable-to-authenticate-you/3614/6 "2021-10-26T10:37:26Z")

</div>

It seems indeed related to the let’s encrypt issue.

I would suggest to try:

- if you are using docker in production, run a `curl https://api.forestadmin.com` from the host & inside the container
- if you are not using docker in production, just run a `curl https://api.forestadmin.com` on your production machine

Depending on the response (404 or SSL issue), share the response here and I will help to further investigate 🙂

If you want, we also have a lot of thread discussing about this issue with a few different solutions (That are depend on the way you are hosting your production environment).

- [What to do when you get "SSL\_connect returned=1 errno=0 state=error: certificate verify failed (self signed certificate in certificate chain)"](https://community.forestadmin.com/t/what-to-do-when-you-get-ssl-connect-returned-1-errno-0-state-error-certificate-verify-failed-self-signed-certificate-in-certificate-chain/2825)
- [🚨 Forest down (SSL issue) - Trouble logging in - error 400: Invalid client id 🚨](https://community.forestadmin.com/t/forest-down-ssl-issue-trouble-logging-in-error-400-invalid-client-id/3376)
- [Let's Encrypt CA expiration](https://community.forestadmin.com/t/lets-encrypt-ca-expiration/3429)

(Search for either SSL/Let’s encrypt related threads)

---

<div class="post-metadata">

**Author:** ![Raphael](https://avatars.discourse-cdn.com/v4/letter/r/edb3f5/32.png) [@Raphael](https://community.forestadmin.com/u/Raphael)\
**Post date:** [October 26, 2021, 10:41am UTC](https://community.forestadmin.com/t/unable-to-authenticate-you/3614/7 "2021-10-26T10:41:19Z")

</div>

![Capture d’écran 2021-10-26 à 12.40.33](https://europe1.discourse-cdn.com/flex013/uploads/forest/original/2X/c/c1ce6e18fa08e20ba5c2c84c020ce65b95683164.png)  
here’s what I get from running [https://api.forestadmin.com/](https://api.forestadmin.com/)

I’ll look into the other threads thanks !

---

<div class="post-metadata">

**Author:** ![anon39848301](https://avatars.discourse-cdn.com/v4/letter/a/b9e5f3/32.png) [@anon39848301](https://community.forestadmin.com/u/anon39848301)\
**Post date:** [October 26, 2021, 10:48am UTC](https://community.forestadmin.com/t/unable-to-authenticate-you/3614/8 "2021-10-26T10:48:02Z")

</div>

From your production environment, right?

(I shared a bunch of thread since they are a lot of way to find exactly where the issue is coming from, but I’m happy to help if required).

The issue is related to the `HTTPClient` gem (See the the [associated github](https://github.com/nahi/httpclient/issues/445) issue).  
The monkey patch proposed in the Github issue is the one we deploy (In the [Release v6.6.3 · ForestAdmin/forest-rails · GitHub](https://github.com/ForestAdmin/forest-rails/releases/tag/v6.6.3)), however it’ll still not work if your root ca list on your hosting provider is not up to date.

I can spot that you are still running 6.3.2, so in your case, an update to the latest 6.6.3 of the forest-rails gem may be enough 🙂
