Can't create new resources

It needs to be different from dev, devel, develop, development, local or localhost. That’s why I was suggesting Staging

Yeah, that fixes the issue. Is this documented somewhere or is it a bug on your side?

As for the creation issue, from the data you provided, I can see that the id field is missing from the response.

As mentioned in the documentation you need to have a unique id in the Smart Collection for it to work correctly


It’s a bug from our side that we are aware of, and it will be solved ASAP

No wait, you asked for the data in not in the response. In the request I don’t have any IDs yet.
Do you mean in the response I pass to the serializer, correct? Let me check this.
What I don’t understand is why this stopped working. We never sent an ID in the creation route. For the GET route we have IDs of course, but for the POST we never sent an ID and it worked from the beginning. Is this an update on your side? I’ll double check here and will let you know.

The data I would like to see is the data you pass to the serializer here


Ok, I’ll check and let you know. Just a moment.

Hi Olesya,

This solved the issue. We serialized the id of the newly created resource and sent it back in the response and the bug is gone. This still intrigues me tough because we created a bunch of resources before without sending the ID and we never faced this error.
I’d like to suggest a better error message when this happens, by the message I was getting: This collection does not exist I would never figure out that this is the issue.
I appreciate your attention and support.


What is still not fixed is the Activity tab. The API call to times out or returns 500.

It says missing Allow Origin Header.

Hello Nathan,

Would you mind opening a different ticket for this issue to keep better track of it? Thanks

1 Like

Sure, I just created a new issue.