Forest Admin stuck in refresh loop

Expected behavior

It should redirect to the correct environment.

Actual behavior

The app keeps refreshing and is stuck in this state. See the attached gif.BrokenFA

Context

This started happening after the following:

  1. We have a local environment where the environment has a backend url of http://localhost:3000.
  2. We required to test this environment using an ssl connection due to an issue we were having and we changed the backend url to https://localhost:3000.
  3. This worked perfectly and we changed the environment back to http://localhost:3000 after the tests were completed. This is when the issue started.

Hi ! Can you tell me what your project is ?

Hi! The following are the project specs:

  • Package Version: forest-express-sequelize: 6.6.3
  • Express Version: 4.17.1
  • Sequelize Version: 5.21.13
  • Project Name: Bridgement

Looking at your environment, it seems you are running forest-express-sequelize 1.1.17 :thinking:
Can you check the meta property of your forestadmin-schema.json and tell me what’s in there ?

Here is what is in the meta tag!

  "meta": {
    "database_type": "postgres",
    "liana": "forest-express-sequelize",
    "liana_version": "6.6.3",
    "engine": "nodejs",
    "engine_version": "14.15.3",
    "orm_version": "5.22.3"
  }

Do you have an error in your web console ? And on your admin backend ?

No, I don’t have any errors in either one. The backend, however, shouldn’t have any impact on this as if my local server was not running the forest dashboard would still load but then you would get the error:

Your admin backend is unreachable

Is your project Bridgement or Bridgement.1 ?

Sorry yes Bridgement.1!

1 Like

I think I was looking at the wrong one :sweat_smile:
Your forest-express-sequelize version is fine.
Can you double check that no https://localhost:3000 remains in your code ?

if my local server was not running the forest dashboard would still load

Can you try to check if it’s the case ?

Yes I have checked my server is running on http://localhost:3000 now and when I shut my server down and try to load up forest admin the same issue occurs!

Let’s try this: clear your browser cache, it sometimes can cause issues if your endpoint is not properly updated there.

Ok tried clearing the cache and I tried it in an incognito window as well and still the same result.

What was your issue when not using SSL ?

@DillonParfitt are you the only one getting this error ?
Can you try to logout/login ?

@Nicolas_Sailly no we are all getting this error, I did try logging out and in again and it still was doing the same thing.

Regarding SSL it was an issue we were having with CORS for smart actions that have “type”: “single” specified.

Hello @DillonParfitt,

Can you proceed with the following steps?

  1. Open the developer console on your browser
  2. Click on the network tab
  3. On Firefox, click on the cog on the right, and select “Preserve logs”, on Chrome activate the option “Preserve log”
  4. Access to your page
  5. Try to identify the different urls your browser is trying to access. Are they the same? Is it a reload or a redirection made from the browser?

In particular, I would like to know if there is a redirection between http and https back and forth.

Hi @GuillaumeGautreau thanks for the help,

Here are the redirects showing in the network tab:

Are these the ones you are after?

@DillonParfitt thanks for sharing this. I’ll investigate on this. Could you also show urls of the initial HTML page, that gets reloaded? I would like to know the URL of these loaded pages.

@GuillaumeGautreau this is the URL: https://app.forestadmin.com/Bridgement.1/Local/Operations then it redirects to: https://app.forestadmin.com/Bridgement.1/Local/Operations/data/some-key/index
and then back to the first one.