I can't coming to my production environment

:warning:This is a template you must use to report issues. :warning:
You can also drag images, videos and include Preformatted text.

Feature(s) impacted

I can’t connect to my production environment, I get the message you are not authorized to access this project
unnamed

Observed behavior

I noting that when I select Production there is a request to http://localhost:3310/forest/authentication/callback?code and got a 403 response, some strange because it should be pointing to my production API, shouldn’t?

Another strange thing that i noted is that when I was using development environment an mi project was running over http://localhost:3000 the request I was gotten the same error, http://localhost:3310/forest/authentication/callback?code and got a 403 response when I can connect my develop environment was becouse I run mi project over port 3310

I suspect that the route http://localhost:3310 was hardcoded and that is the reason why I can’t connect.

I already put mi keys in my production server

  • “forest-express-sequelize”: “^8.4.8”,
  • Express Version: ^4.17.2
  • Sequelize Version: ^6.13.0
  • Database Dialect: postgres
  • Database Version: postgress-12

Expected behavior

I expect that I could select the production environment and connect with mi models and get my data

Failure Logs

In this optional section, please:

  • include any relevant log snippets if necessary,
  • or remove this section if left empty.

Context

Please provide in this mandatory section, the relevant information about your configuration:

  • Project name: Node_Backend
  • Team name: Operations
  • Environment name: production
  • Agent type & version:
  • Recent changes made on your end if any:

Hello @ArkLuis and welcome on our community forum !

Can you share the response of the failing network request please ?
+ Can you check your APPLICATION_URL set in your .env file is the right one? :slight_smile:

Kind regards,
Louis

Hello @lclisson

Of course is this is the request
image

And this is the response

{“error”:“invalid_client”,“error_description”:“The provided client id does not match the id received at first place.”}

Referent to the APPLICATION_URL both production and develop was set correctly like say in the documentation. I think that becouse I can connect de production environment and saw the Finish button when deploy to production

Thanks for your quick answer,

Did you set a static client id ? Is your forestadmin application using load balancing ? :slight_smile:

Kind regards,
Louis

@lclisson

Mi production environmetis is using a load balancer referent to the client id where I can see it