MongoError: Authentication failed

Hello to all,

I try to connect my mongoDB to forest admin without success.
Each time I get this message :

Cannot connect to the database due to the following error:
MongoError: Authentication failed.
The specified path cannot be found.

So I tried to create a new database, but I still get this message.

Thanks for your help.

Hello @Julie :wave: Welcome to our community :confetti_ball: :tada:

May I ask you to provide the database url you are using please ? You can find it in the .env file, search for the DATABASE_URL variable.

Thanks in advance :pray:


Hello @Steve_Bunlon,
My database is on localhost on port 27018
I try on port 27017, I have the same message.
I also tried without password, I still have the same message


Hello @Julie

Did you try with advanced options from the form?

Mongo can use authentication with the ?authSource=admin parameter.
Could you let me know if it is your case?

Here is a mongo-db docker containerized example.

Thank you very much, i don’t see the advanced options.
It works