New collection not detected

Feature(s) impacted

new collection

Observed behavior

schema not updated, new collection not automatically added

Expected behavior

new collection will be added to the ui

Failure Logs

**×** We are not able to detect a Forest CLI project file architecture at this path: /path/to/root/project.: Error: No "routes" directory.


  • Project name: WescoverContentAdmin
  • Team name: Operators
  • Environment name: Development | nimrodmaltz
  • Agent type & version: “forest-express-mongoose”: “8.7.6”
  • Recent changes made on your end if any: added forest and models files for new collection

hello again,

i am doing something wrong.
i am trying to add a new collection but cant seem to succeed.
the documentation states that a new collection will be recognized automatically when added but this doesnt seem to happen. i added a new table/collection to the database, also, added the schema to the models folder and tried to run forest schema:update.
the update fails with an error stated above, the routes folder is inside a src folder.
i tried seeing if its hidden in the ui, but its not there…

thanks in advance,

Hello @nmz,
The CLI checks if your folder architecture is correct. It throws an error because it does’t see the “routes” directory. A potential solution is to run forest schema:update at the same level of your “routes” directory.

hi @Alban_Bertolini ,

i tried that, it says it should be in the package.json level

thank you,

Are you still blocked ?

yes, still unable to create a new collection