Smart action is not shown

In my environment I have a Smart Action for a collection. Editing the layout I can see that the smart action exists, but it’s not shown in the Actions drop down menu.

Expected behavior

The existing smart action is supposed to be shown in the Actions drop down menu.

Actual behavior

The smart action is not shown in the Actions drop down menu.

Failure Logs and evidences

This is the Layout Editor perspective:
Screenshot 2020-09-29 at 10.36.24

As you can see, there is a smart action.

And this is what I get when I exit from the Layout Editor: the smart action is not shown:

In this collection, I have a couple of Segments. But there’s no resctriction for the Smart Action with the segments:

The problem happens in all the segments.

Maybe I’m doing something wrong, but I can’t figure out which is my mistake :man_shrugging:. May you help please?

Thank you in advance.


The problem only occurs in the environment stg-datamix. I can see the smart action in the enviroment dev-datamix (same backend software underneath).

I tried to copy layout from dev-datamix to stg-datamix and all the settings get copied. But the smart action is not shown.

Edit: The two above sentences are not true, I was wrong. It’s the same problem in both environments.

  • Package Version: "forest-express-sequelize": "^6.3.8"
  • Express Version: "express": "~4.17.1"
  • Sequelize Version: "sequelize": "^5.22.3"
  • Database Dialect: postgres
  • Database Version: 12
  • Project Name: Sailsquare

Hi @Matteo :wave:

Thank you for your feedback :pray:. Could you share the configuration (the code in forest/my-model.js) of your smart action? Also, could you check if you see it in your .forestadmin-schema.json file of your stg-datamix environment?

Just to be sure, is it a bulk action or a global action? Looking at your screenshot, it seems that you try to use it as a global action (without selecting any records) so I would like to double check the configuration is OK.


Hi @rap2h.

Thank you for your feedback.

I’m afraid my question was stupid. Sorry. I was just forgetting to select the records to apply the smart action to.

Sorry again for the question.
Thank you.