Undefined method `env_secret' for ForestLiana:Module

I’m using Rails and Ruby 2.7.2
Trying to set up FA with :

rails g forest_liana:install fb13fdca...fds

Failure Logs

/Users/phil/.rvm/gems/ruby-2.7.2/gems/forest_liana-6.6.2/lib/generators/forest_liana/install_generator.rb:11:in `install': undefined method `env_secret' for ForestLiana:Module (NoMethodError)

   3  module ForestLiana
\e[0m   4    class InstallGenerator < Rails::Generators::Base
\e[0m  10      def install
\e[0m❯ 11  \e[1;3m      if ForestLiana.env_secret.present?
\e[0m  16        end
\e[0m  18        route "mount ForestLiana::Engine => '/forest'"
\e[0m  20        auth_secret = SecureRandom.urlsafe_base64
\e[0m  22        puts "\\nForest generated a random authentication secret to secure the " +
\e[0m  28        if File.exist? 'config/secrets.yml'
\e[0m  68      end
\e[0m  69    end
\e[0m  70  end
\e[0m```

Thanks

Hello @pierrax and welcome to the Forest community.

Could you try to remove your config/secrets.yml file relaunch the command?
Or just remove the lines concerning forest if you have more things in it.

Thank you @Guillaume_Deslandes.
I tried but unfortunately same error.