Your server encountered an error (getaddrinfo ENOTFOUND postgres postgres:5432)

Expected behavior

I’m expecting to be able to visual my data.

Actual behavior

I setup forest admin with docker (the website gave me the command which worked perfectly). But then I get the kind of error on all the models.

Failure Logs

the logs tell me:

resp ==>

    "errors": [
            "status": 500,
            "detail": "getaddrinfo ENOTFOUND postgres postgres:5432"

Would you have any ideas?

Hi !
It looks like your database il is not reachable at the address defined in your .env
Can you check if the right url is defined for DATABASE_URL ?

Thanks for your quick response!

DATABASE_URL: postgres://[user]:[pass]@postgres:5432/db

This is my database url with my actual user and password, same one I use on my server.

The docker install worked correctly, so I guess the db was found.

I tried to create a project via docker + postgres and I don’t have any issue on my end.
Can you try to access your db via the psql cli to check that the connection URL is right ?
For example, I use psql -h localhost -p 5435 -U postgres