'browseEnabled' access forbidden on table

Expected behavior

I should be able to open a collection in the forest interface and see all the records.

Actual behavior

I receive an error “[forest] ‘browseEnabled’ access forbidden on table”

I’m not sure what I should revise to remove this error, and wanted to make sure it was something that I need to fix on my end?

Thanks!

Hey @Matt :wave: ,

Do you have the Allow record details display option checked on this collection settings?

If checked , clicking on a record from the table view will display the record’s details page. If unchecked , an “Record access forbidden” message is shown. :warning: Note that if you hide a collection (from the left side bar), this option will automatically be unchecked . You will have to manually check it to be able to access records from other collections (from relationship fields or related data).

See our documentation

Let me know if that helps

Hey @louis!

Yes, I do have “Allow Records Details Display” checked for that collection. I am now also getting a similar ‘addEnabled’ access forbidden error on a collection I also have checked the option to add records to. The window works to add a new record, but when I submit it gives me the error. This is what the pop up error window shows:

Shoots creation failed: <!DOCTYPE html> <html lang="en"> <head> <meta charset="utf-8"> <title>Error</title> </head> <body> <pre>ForbiddenError: Forbidden<br> &nbsp; &nbsp;at /Users/mattlaughlin/Documents/repos/content-admin/node_modules/forest-express-sequelize/node_modules/forest-express/dist/middlewares/permissions.js:86:16</pre> </body> </html>

Hey @Matt,

Thanks for your reply.

Let’s try to take a step back to figure out what’s going on here.

  • Can you tell me what is the project name where you have the issue?
  • On what environment do you have this problem? Is everything working well on another environment?

Thanks.

Hey @adriguy

For sure!

  1. Content Admin
  2. Yesterday I was running into the error in production and local, but today (with no changes to production) I’m only running into the issue locally.

@Matt this is very strange :thinking:

When you’re having the “browseEnabled” issue, do you see the Your server encountered an error page (the one you sent) or do you see the collection not found page (the one just below)?
image

Still on that issue (“browseEnabled”), do you have any error into your browser network?

Thanks.

@adriguy

  1. I get a “Your server encountered an error” popup, as displayed above.
  2. I get two 403 errors in my browser network

Hello @Matt,

It looks like your permissions does not support the fact that you can browse through a collection. But the fact that you can do it on your production environment doesn’t seem to be the normal behavior, I looked at it from our side and the two environments seem to have similar configurations. Can you try to disable “browse enabled” → reactivate it → restart your server and tell me if the error persists?

Thanks,
Let me know if it helps :slight_smile:

@lclisson Restarting the server did the trick, thank you! When in doubt, reboot. :slight_smile:

1 Like