Cannot create a new environnement

This is a template you can use to report issues. You can also drag images, videos and include Preformatted text

Expected behavior

Create a second production environment.

Actual behavior

Cannot create a new environment.

Failure Logs

masterblue creation failed: A production environment must be created before any other environment


  • Package Version:
  • Express Version: 4.16.3
  • Sequelize Version: 4.37.7
  • forest-express-sequelize Version: 5.0.0
  • Database Dialect: Postgres

Add a note on that: we have already 5 environments:

  • 1 production
  • 1 stage
  • 1 development
  • 2 local

Hello @killix,

Could you give me the name of the project which is having this issue so I can check what is happening?

Thanks in advance

The name of project: master_blue


Hi @killix,

I am sorry but we can’t find a project having the “master_blue” name.

By the way the platform won’t allow you to create several production environments per project.
From this point of view, it seems normal to me that you can’t create a second production environment (although, the error message in this case does not look good).

Out of curiosity, why would you like to create a second production environment?

Thanks for your help.

I am trying to add a new development environment.
My steps are:

  • click on the button : “Add a new environment”
  • Then “Add a new development environment”

Once i filled the form:

  • Name of the environment
  • Admin backend URL

i got this error: “masterblue creation failed: A production environment must be created before any other environment”

Which is an issue because we have already a production environment.
So how you think, we trying to add a second Production environment?

I just read your description of the expected behaviour.

Anyway, I did a few manipulation on our end.
Can you try again to create an environment with a name that does not contain “production” (“new development” for instance) and let me know if it helps?

Thank you.

Hi Arnaud,

Looks like our whole ForestAdmin is now broken. Any idea what might have happened?

PS. This is urgent as it means our production Forest is now down and unusable for our operation team

As for adding a new environment, we tried with various names, including “Test”, always the same error

Hi @Esteban,

All your 5 environments look properly setup, and we didn’t touch the current production environment.
So I have no clue right now.

Can you access other environments than the “production” one?

Hi Arnaud,

No every environment are now broken with this error. Which is really weird. Seem to be something related to Forest loading our projects, which might be related to errors on creating environment?

Any thought what might be wrong? We’re onboarding lot of customers today but are completely paralyzed. Happy to jump on a quick call if it helps

Hi @Esteban,

I tried a few manipulations to fix your project access.
Did it change something?

Yes it’s back working! What changed? Anything we messed up on our end that we could have fixed?

And should we try adding the environment again?

You did not mess up anything on your end
My first cleaning of your 2 inactive and “production like” environments was partial (probably a cleaning process that failed on our end, I don’t know yet) and lead to this broken state.
Sorry for the inconvenience.

You can try to create a new environment :+1:

Looks to be fixed as well by these changes. Thank you!

Have a good evening

1 Like