Collection parsed correctly but web throws error can't login

I’ve installed Forest Admin for NestJS following the guide. Everything works well and the lib parsed data from the server correctly but I can’t open dashboard because it says

Agent unreachable

Forest Admin can’t reach your server.

Hello @Ilya_Sayapin,

Sorry to hear that. You must have an issue with the server connectivity or the authentication.

Can you share more information (Netwoks tab, Project name, Logs from the browser if any, ...) so we can help you find what causes the issue?

You can find those information using the developer tools of your browser:

  • developer tools of your browser → Network tab
  • developer tools of your browser → Console tab

Kind regards,

Sure! Here is some more info:

When I started the forest app as microservice using forest cli it runs correctly but issue the same forest web ui dosen’t see my app. When I try to open it on http://remote_ip:3310 it gets text response “Not Found”

Here is the link to test instance:

Hello @Ilya_Sayapin,

I’m not sure to fully understand what is happening.

Indeed if the call to /forest/authentication fails that’s weird! But I see that it calls http://localhost:3000 and not PORT 3010 as you reference in your last message. :eyes:

Can you share your Project Name?


I’ve just tried to create new standalone verions on default port 3310. the project name on Forest chat_hunter_ai

I used npm and Forest CLI the generated project is pretty straightforward and run it using pm2 start index.js --name forest

But the issue is the same for me. Can’t understand what’s wrong with the procces, the guide was pretty simple. Also I checked that 3310 port is available and the remote IP as well

When I tired to integrate in inside Nest App it was also pretty easy. But the issue is again like on messages before. After trying several other solutions I got back to this tool and trying to set up it for me because the Forest app itself looks perfect for me

Also you cant contact me via email if you want

I tried the easiest way in nuew project cht_test just connect via link to remote db using Forest UI and it worked!

But standalone or Nest version still doesn’t work. Here is my .env file and docker compose

Hey @Ilya_Sayapin,

Sorry for the late reply.

You are talking about a remote IP? Did you try to create your project on a remote server? In this case, it’s pretty normal that it doesn’t work. Development environments are meant to be used locally. (localhost)

But you can change the host using --appHostname '' while creating your project with the CLI.
Or during the What is your local application URL? onboarding step you can also put your remote URL which must be a domain.

We force our clients to use HTTPS remote URLs for security reasons (and browser compliance too).

Do you have any domain that redirects to your remote server? You should better use a domain if you wish to onboard on a remote server.

Let me know if it helps.

Kind regards,