Date field currently displaying as date + time - no way to remove time

This is a template you can use to report issues. You can also drag images, videos and include Preformatted text

Expected behavior

For a field of type date in Sequelize model:

dateReception: {
  type: DataTypes.DATE,
},

I expect to see a date in FA and not a date + a time.
I know Sequelize considers Date to be Datetime but I should be able to display dateOnly feature in FA.

Actual behavior

I see a date + a time, and when I enter layout editor mode, I can’t change display settings for this field, the “select display widget” dropdown is greyed out, and the cog yields “this widget does not have any setting”.

I cannot edit the way this date field is displayed. The options are greyed out, with no explanation/reason as to why that might be

1 Like

Hi @francois_Ruty,

I think what you are looking for here is the Edit Widget.

  1. Instead of default, select the datepicker widget in the EDIT SETTINGS section
  2. Click on the 1st cog, you’ll find an empty field where you can type your desired format e.g DD-MM-YYYY or any other format as long as you use the moment.js syntax

We are currently working on making the default widgets simpler to use, thanks for your patience!

Let me know if you need anything else :smiley:

Hello thanks but this is not the problem.

I can edit the Edit widget, no problem.

But I cannot edit the Display widget, it’s greyed out… How can I edit the display widget so that date is displayed with a format I can choose?

A screenshot speaks louder :smiley:

Again, it’s the 1st cog on the EDIT SETTINGS you should click on. Chosen format will also apply to the date’s DISPLAY SETTINGS.

I reckon it’s not intuitive, thanks for bearing with me.

1 Like

thanks, it’s clearer now

1 Like