Deployment in the cloud

Feature(s) impacted


Observed behavior

I just created a new project on the cloud
When I try to deploy the code (when I run npm run forestadmin:build:package:publish) I get an error (cf screenshot)

But when I go to the production pannel it seems to be deployed correctly

Expected behavior

No error message


  • Project name: Azybia
  • Team name: Azybia
  • Environment name: Production
  • Agent technology: nodejs
  • Agent @forestadmin/agent 1.41.1
  • Database type: postgres
  • Recent changes made on your end if any: -

Hello @Quentin_Somerville1,

I have just tried it but couldn’t reproduce the issue,
Did this occur to you before or is it the first time ?
Could you ensure that your dependencies are up to date ?

If nothing else, are you using a particular network setup ? reverse proxy and such…

For more information, this error is only related to events meant to notify once the publication of the code is done. So as you have pointed the deployment will still proceed smoothly.

Hello @dogan.ay

I just created the project, it’s the first time I try to deploy.
I am migrating a project with the self hosted agent to a new project in the cloud (I copied the sources)
I am quite sure my dependencies are up to date (npm install does not change anything)
I don’t have a particular setup.
If deployment works it’s ok but it’s weird

I see that you’ve pushed a few times, does it happen every time ?

I’ll create a bug report on our side to try to fix this if we manage to reproduce.
Thanks for the report

1 Like

Yes it happens every time

I still wasn’t able to reproduce but based on the information you have shared I released a fix, please update your @forestadmin/forest-cloud and tell me if it is better :slight_smile:

Hi @dogan.ay

I upgraded @forestadmin/forest-cloud from 1.9.15 to 1.9.17 but I get the exact same issue