Unable to deploy stage changes in server

Trying to deploy changes in local to staging environment but changes are not getting reflected

Hello @Amit_Mundra ! :wave: Welcome to our community :tada: :confetti_ball:

Could you please add the info that are requested when creating a new community post asking for help? All these info are very important for us to understand the context and will help us dig into your issue.

This is a template you can use to report issues. You can also drag images, videos and include Preformatted text

Expected behavior

Please describe here the behavior you are expecting.

Actual behavior

What is the current behavior?

Failure Logs

Please include any relevant log snippets, if necessary.


Please provide any relevant information about your setup.

  • Package Version:
  • Express Version:
  • Sequelize Version:
  • Database Dialect:
  • Database Version:
  • Project Name:

Thanks in advance

Hi @morganperre,

Expected behavior

changes should be available in staging environment

Actual behavior

changes aren’t visible at the moment

Failure Logs

I don’t have any relevant log snippets to share.


We creating a new staging environment and tried deploying on it but its showing the same as production environment

  • Package Version: ^7.0.0
  • Express Version: ~4.17.1
  • Sequelize Version: ~5.15.1
  • Database Dialect:
  • Database Version:
  • Project Name: Zepto

Hi again @Amit_Mundra,

  • I’m not sure to really understand your problem. When you say "tried deploying" what do you mean ?
  • Which changes aren’t visible ?
  • Can you connect to your staging environment ?

We need more informations to have a clear description of what may have failed here.

Kind regards,

Hi again @morganperre

  • tried deploying means :- We have made some changes in our local and we are trying to deploy that on forest admin for staging env but out changes are not getting reflected.

  • Which changes aren’t visible :- Our latest changes are not getting reflected. It is visible in development but not in production and staging

  • Can you connect to your staging environment ? :- Yes

1 Like

Thanks for those informations.

Which command are you using to deploy those changes ?

Your project seems to be in Development workflow. Here’s some documentation on how to deploy changes (to production) and push changes (to remote environment).

I hope this will help you.


HI @morganperre ,
I used the above given documentation.
That didn’t help.

We used the following commands :-
forest deploy
forest push

Amit Mundra

Hi again,

Can you try to upgrade to the latest version (if it’s not the case) ? :pray:

npm install -g forest-cli

I see multiple projects around Zepto (Zepto Admin, ZeptoAdminPanel, …) can you confirm the issue appear on Zepto ?

A colleague will take the relay on this subject, as he is the expert of forest-cli.

Thank for your patience. We will find the culprit !

Kind regards,


Sure we will try by upgrading to the latest version.
The project name is. :- Zepto which I can see in the settings.

Amit Mundra

Hi Morgan,
we have tried forest deploy but in documentation there was mentioned like forest deploy but in reality it is asking for environment name. i have updated the forest-cli as well

Hey @Kashish_Maggu,

Could you share here the name of the branch you are trying to deploy? I’ll check on my end if I can spot any issue with it.

staging_test, you can use this branch

Could you confirm that your project in running with the FOREST_ENV_SECRET mentionned in the screenshot you shared? (I’ll remove the screenshot since it contains sensitive informations)

Logging process.env.FOREST_ENV_SECRET would make sure you are connected to the correct environment.

no its not using that secret,
we tried with that and then auth failure was coming


Maybe we should focus on the authentication failure then, since the mentioned environment secret on your screenshot is the one to use with the staging_test branch, according to what I can see on our end.

Hi @jeffladiray ,
Any suggestions what should be the next steps we should try. We even tried to deploy our changes in production environment. But that also didn’t work.

Can we connect over Zoom or Google Meet?

Amit Mundra

we are getting this error when we use those auth and env secrets

We usually prefer to do support here, in order to help other community members that might encounter similar issues.

@Kashish_Maggu looks weirds indeed.

Could you console.log(process.env.FOREST_ENV_SECRET) just to make sure the one used is actually the one required here?
You should see the environment secret matching the previously shared screenshot.

Also, even though your project does not start, could you try a forest switch staging_test on your local environment to check if it works?

hey @jeffladiray,
It was the issue with json schema.We have fixed it. Thanks for your support and help