Error during instant setup

I’m trying to create a small project using the instant setup.

the project name is

I’m running on Azure SQL Database (so technically MsSQL)

I get this error when filling my connection string:

I already added the forest admin IPs to my white list.

Do you have any idea ?

Hello @Simon_BRAMI1,

Did you try authorizing your own IP and open the DB from your computer?

I think that the IP address in the error message is not correct, but it’s due to the internal implementation for opening requests with the same static IP address.

Which IP address did you authorize on your DB?

Hello Guillaume,

Yes my own IP is authorized and works fine on DataGrip.

And I added those:

Hello @Simon_BRAMI1,

So you have followed the following link

We got two kind issues from your tries:

Unable to connect to the given uri: mssql://XXXXXX.
Connection error: Server requires encryption, set ‘encrypt’ config option to true.

Unable to connect to the given uri: mssql://XXXXXX.
Access denied error: Cannot open server “” requested by the login. The login failed.

Unfortunately, I don’t have an Azure SQL Database to try it myself.

Looking at some threads on the web, It could be an issue with SSH tunneling.

They propose a workaround, add the username to the URI:

Also please check that in the Azure SQL server the port 1433 should be opened or add a new inbound rule with this port.

Let me know if it helps.

Kind regards,

What is the difference between columns 2 and 3?

It’s just in case I need to setup IP ranges :wink:

My username and password are already filled in the URI, the port 1433 is also already setup by default

My URI looks like this:


1 Like

By the way this issue is only if I don’t require TLS so you can consider it “fixed”

1 Like

the way this issue is only if I don’t require TLS so you can consider it “fixed”

Indeed, Azure SQL Database needs TLS/SSL.

I just doubled check the Azure SQL Database documentation for Node.js and mssql driver.
I don’t understand what could cause the issue. There maybe a specificity that we have missing with AZURE_SQL_AUTHENTICATIONTYPE=azure-active-directory-default

We will try to set up this on our side and try to understand the root of this issue. I will keep you updated when we have some more news. :pray:

Some Azure resources on this topic for reference:

Kind regards,

By default Azure SQL Database is usable with User and Password created during setup, I have never used the “Active Directory” auth.

Also, when configuring other Forest projects by setting my own backend, I use the same mssql:// URI format to connect to Azure Databases which works fine :slight_smile:

Don’t know if it will help, let me know how your investigation goes!

Superbe that’s very interesting since we have some specific handling in the Cloud to keep your URI secured.

Be sure that we will keep you updated but it might take a few days to put all of it together. :pray:

Kind regards,

1 Like

Thanks man :pray:

Let me know if you need me to test things

Hello @Simon_BRAMI1,

We have conducted some tests and we have run into the same issue as you Cannot open server “” requested by the login.. Even though, it is likely a side effect of another issue (we need more time and extended tests to verify this).

We think that we encountered an issue close to the following: MSSQL - tables in a non "dbo" schema preventing onboarding
Mainly, we don’t support schema correctly during DB introspection. We have already started to work on this issue.

I will inform you once we have more information/news.

Kind regards,

Hello Morgan,

If that can help, the schema hosting my business tables is dbo :slight_smile:

Good luck with that issue.

1 Like

Hello @Simon_BRAMI1,

Well, it took a while to fully investigate this one. First, I want to thank you for your feedback. :pray:

We detected an issue in our fixed IP (used for whitelisting) functionality thanks to you.
For now, we decided to remove the MSSQL Cloud onboarding since the issue cannot be tackled right away.
We will investigate more time in the future to reenable it for the cloud onboarding.

We will update you when the situation comes back to normal. Let me know if you have additional information.

Kind regards,

1 Like