Error message -"Admin backend is unreachable"

Feature(s) impacted

Unable to access admin panel of forestadmin.

Observed behavior

I have been trying to create a forestadmin application using a ruby on rails data source.
After following all the steps mentioned during the setup, when I run rails server on vs code, although my server is running successfully on vs code (as seen in the attached screenshot), when I open on my browser, I only see a blank screen. Furthermore, when I try to unlock my data on the forestadmin panel, I get an error message saying “Your admin backend is unreachable. Please check that it is running and respond to” Hence, I have been unable to access the admin panel that I am trying to build on my rails application.

Expected behavior

Getting access to the forestadmin application which uses the rails application as a data source.


Please provide in this mandatory section, the relevant information about your configuration:

  • Project name: colending
  • Team name: credavenue
  • Environment name: development
  • Agent type & version: …
  • Recent changes made on your end if any: changed postgres port from 5432 to 5434 in my local

Hi @Ashna !
As stated in you console, it seems you are using a deprecated version of forest-rails, can you try to upgrade ?

Upgraded to ‘forest_liana’ version 7.4.5. That deprecated version error is no longer popping up when I run rails server. But the error message on forestadmin panel ‘Please verify that your admin backend is correctly configured and running, and that you have access to the internet’ is still popping up.’ Except that on thr forestadmin panel, I’m not being asked the login and I’m directly getting the error popup (as visible in the attached screenshot). How to resolve this issue?

This is the log. I’m getting an 500 response - internal server error.

Did you follow these instructions to upgrade to v7 ?

Yes. I did follow those instructions to upgrade to v7

Hello @Ashna,

We will try to find what cause the issue. I need some informations in order to help you.

  1. What was your forest_liana version before upgrading to v7 ?

  2. Can you share the network tab of your browser with the failing call to the agent ? It would really help.

For the second step, this can be done using the developer tools of your browser:
  • Open the developer tools
  • Reproduce the error (you need to received the error after opening the developer tools)
  • Open the network tab
  • Locate the call that fails
  • Paste the response’s body & take a screenshot

Kind regards,

I have managed to resolve this issue. Thank you for your help.