Filter working in dev but not in production

Feature(s) impacted

  • Filters
  • Segment
  • Flattened fields

Observed behavior

On my dev environment, I have a filter on a flattened field that works fine on the dev environment but it doesn’t in production.

Expected behavior

I don’t see any reason (in my database) why it would work in one env but not the other in the code.


Project environment: Production
Version on both Dev and Prod: forest-mongoose-express 8.4.4
I did copy the layout from the Dev env to the Prod env

Hey @jganichot, and sorry for the super delayed response (It seems like your thread was missed :sweat:)

According to our changelog, it seems like some update was made on forest-express-mongoose about filter. Could you check if everything is working as expected on forest-express-mongoose@8.5.0?

Thanks in advance :pray:


Hello there!

Unfortunately no, it’s still not working.
I even updated to version 8.6.0:

Screenshot 2022-02-10 at 17.02.02

The CSV export is still not working either, all the ObjectIDs are serialised as a Buffer object like this:

Screenshot 2022-02-10 at 17.28.16