Getting error while pushing changes to remote environment

Hi Team,
I am trying to push the changes from my local forest branch to staging enviroment named ‘qa’ in forest-admin. I am getting the below error.

Failed to push branch: source and destination environments must have the same schema 

I have checked the .forestadmin-schema.json files of my development and remote branches. They are similar.
When i have tried to send the schema to forest server manually using the forest schema:apply --secret YOUR_FOREST_ENV_SECRET command, i got the below error

Invalid json: Unexpected number in JSON at position 104989 

Please help me out to resolve this issue.

Ajith mani V.

Project Name: PlutusAdmin

Hi @ajithmani,

The first message about “failed to push, source and destination…” is relevant.

To push layout changes from an environment to another, they must be compatible. The file forestadmin-schema.json must be the same for both environments. Only meta.stack inside forestadmin-schema.json can be different because it’s ignored.

To have the same files, you have to merge the development server to the staging server and restart it.
Be careful, sometimes this error happened because some versions fields are differents.


HI @Sliman_Medini,
I have merged my dev server to staging server and restarted it.
But still i am getting that error


Can you get the forestadmin-schema.json from the dev, and also from the staging?
Like that you can compare them with a tool like diff.


I have checked both the files using Diffchecker
They are similar

@ajithmani I noticed some changes in your development environment.

Do you confirm it’s working now? Was it related to your REGEX with the invalid date field?

Hi @louis,
No, it is not working.
After our talk, i have removed that particular regex validation and tried to push my changes.
Still i am getting the schema mismatch error

Also, when I restart my rails server, schema file is getting changed.