Help for smart segment

Capture d’écran 2022-11-25 à 08.33.33


Feature(s) impacted

Hello @Romain_Devillez,

Thanks for reaching out and welcome to our community :raised_hands:

Could you please tell me:

  • what’s your problem exactly?
  • what agent name and version are you using?
  • what is your project name?
  • if you did check this documentation page?

Thanks.

Problem :
I can’t sort the data in the smart segment.

Agent name:
app.dailyn.forest-admin-backend
“forest-express”: “^9.4.4”,
“forest-express-sequelize”: “^8.5.3”,

I check the documation:
The documentation does not mention using segment smarts with just smart collections.
The documentation uses models, I don’t. I just have data which transit they are not stored on forest.

Thanks for your help.

Hey :wave:

As visible in our smart fields documentation, you’ll need to add the isSortable property to the fields you want to sort by, as well as handling the sort feature manually in the data retrieval route.

Let me know if that helps :pray:

Ok, I added the option but I still don’t see the email field appear in the smart segment.
I want my email to appear when I click on the smart segment.

Thx for your help.



Ok, I missed that in the first screen.

I’m pretty sure the fields option is not available for segments definition.
If you want to show this field on the UI only for your segment, you should be able to do so by enabled the “Independent layout configuration” on your segment, and move this email field as a smart field of your collection (Allowing you to display it in the segment but not in the collection view).

Let me know if that helps.

1 Like