Smart Segment not displayed

I just try to add smart segment on my collection:

collection('client', {
  actions: [],
  fields: [],
  segments: [{
    name: 'Provider',
    where: async () => {
      return {"id": { $in: ['1'] } };

But I don’t see my segment Provider on the interface when I restart my development server. I don’t know why. In addition, there is no log “ok”.

Do I miss something ?

Expected behavior

I want to add “Client” segment on my forest interface.

Actual behavior

I see nothing

Failure Logs

No failure log


Please provide any relevant information about your setup.

  • Package Version: 6.0.0
  • Express Version: 4.17.1
  • Sequelize Version: Mongoose
  • Database Dialect: Mongo
  • Database Version: 4.0.2
  • Project Name:

Hi @aurelien.laclergue !
Once you coded the smart segment, did you set it to visible form the layout settings ?
You can check the documentation here.

Hello @Nicolas_Sailly,

I read the doc but even the simpliest does not work. I dont see the smart segment in the layout settings either.

Can you share the name of your project ?

Ok I find why. I not write my collection name as my file name :confused:

1 Like

Glad to hear your issue is resolved :slight_smile: