Need to run node 14+ but no data fetched when updated

Feature(s) impacted


Observed behavior

Our FA client is currently running on node 12.30.0. We need to update to at least node 14.20 for a package that we need to add. If I change to node 14.20, our client never actually sends database requests. Running locally, it logs the request from the UI and then nothing happens. My db proxies never log any requests and just nothing happens. No errors anywhere.
*We wouldn’t mind updating further - say, to node 20 but not absolutely necessary.

Expected behavior

FA works normally on node 14.20+


  • Project name: scratchpay-payment-service
  • Team name: all
  • Environment name: dev
  • Agent (forest package) name & version:
"meta": {
    "liana": "forest-express-sequelize",
    "liana_version": "8.5.15",
    "stack": {
      "database_type": "multiple",
      "engine": "nodejs",
      "engine_version": "14.20.0",
      "orm_version": "6.29.0"
  • Database type: mysql & postgresql
  • Recent changes made on your end if any: update node

Hello @Brett_Belka,

Ok, we did (quite a long time ago) run forest-express-sequelize with node 14 internally without any troubles. :eyes:

  • Are you sure that any other things are affected by this node bump?
  • Are you integrated inside an existing application (In-App)? Or do you run forest admin on its own (Standalone/Microservice)?
  • Could you eventually share some logs of your agent/backend? (adding the following environment variable could help us dig into the issue DEBUG=sequelize:sql*)
  • What version of Sequelize are you using?

Side note, you can migrate to forest-express-sequelize v9.3.9 without any breaking changes. That might be an option to test the latest version with all bug fixes on our side. Upgrade to v9 - Developer Guide

Thanks for your responses.

Kind regards,

1 Like

@Brett_Belka :wave:

Could you also share here the version of “pg” you are currently using in your package.json?
This could be related to this issue, that is currently fixed in pg>=8.0.3.

1 Like
  1. I’m not really sure. As mentioned, there are no error in backed or client.
  2. We run FA on a standalone microservice.
  3. The logs are literally just request urls.
    a. I’ll try adding that env and see if that changes anything.
  4. As in meta from forestadmin-schema above: 6.29.0

Side note - I’ll try that as well.

We’re running 6.12.1. I’ll try that again, which may work along with other changes but I tried that once before (a while ago) to no effect.

@jeffladiray @morganperre
With the suggested changes, what’s the max node version you think I should be able to run? Would love to go to 20 as longs as I’m doing it…

No additional logs with this added.

@jeffladiray @morganperre

Ok. Thanks y’all! Got it working!

The answer was pg@8.0.3, forest-express-sequelize@9.3.9.
Working with node@20.10.0
Also worked with node 14 and 18.

1 Like

Hey @Brett_Belka,

Awesome. Superbe that it works for you. :clap:

Kind regards,

1 Like