Upgrading to V7 - No response from routes

I’ve upgraded into Version 7 by following these instructions: Upgrade to v7 - Documentation.

It worked in Version 6, but it doesn’t work after upgrade.

Expected behavior

https://app.forestadmin.com/ should show my data

Actual behavior

When I click on a collection,
https://app.forestadmin.com/ call endpoints but have no response.
In debug, I can break on corresponding route, but nothing happens after running.
My browser network inspector stay on “pending”.

Failure Logs

I have no error logs.


I test in localhost before pushing to production.

Here my dependencies in package.json:
“dependencies”: {
“chalk”: “~1.1.3”,
“cookie-parser”: “1.4.4”,
“cors”: “2.8.5”,
“debug”: “~4.0.1”,
“dotenv”: “~6.1.0”,
“express”: “^4.17.1”,
“express-jwt”: “5.3.1”,
“forest-express-sequelize”: “^7.10.1”,
“morgan”: “1.9.1”,
“pg”: “~6.1.0”,
“require-all”: “^3.0.0”,
“sequelize”: “~5.15.1”

Hey @Romain_Gallan,

Did you recently upgrade your node.js version from 10 to 12?
It reminds me of an issue related to the pg package. Could you try to upgrade it and tell me if it works?

Thanks in advance


Yes I recently upgrade my node.js version from 10 to 14.

As you just advised me, I just upgraded pg and it works now.

Thank you very much.


1 Like