Relationships are no longer displaying data

Observed behavior

I can reproduce this locally and in production at the moment that no related data is showing, though I can verify all the data actually exists in the database.

Expected behavior

Should show related data.

Failure Logs

No errors or logs, so leads me to think its not on our end. Can someone from Forest verify?


  "meta": {
    "liana": "forest-express-sequelize",
    "liana_version": "7.12.4",
    "stack": {
      "database_type": "postgres",
      "engine": "nodejs",
      "engine_version": "17.9.0",
      "orm_version": "6.11.0"

Hello @David_Panzarella (project: Rupie) :wave:

It is working alright on my end :thinking:
I am sure the data exist given what the UI is displaying.
If there are any failure logs for this issue, I believe they should be directly in your browser’s console.

Can you double-check for me? :pray:

Same issues here.
CleanShot 2022-09-19 at 08.33.36@2x

As you can see there are 37 records that are not shown here. There is no smart view for this page or errors in the network tab either.

I did notice 1 204 however:


Looking at the Ember extension a bit more at this, it seems like data isn’t getting loaded into the components correctly:

Seems like an infinite loop.

Okay great start :muscle:.
What I’m interested in is if there are any errors in the console tab: from the screenshot just above, it seems you have 3.

Let’s also cover some basics :clipboard::mag:

  • Did you perform any update/upgrade of your agent/forest-admin schema prior to that issue?
  • Any potentially related changes?
  • Any particular configuration for the collection (smart collection or any thing outside the ordinary)?

No recent changes to smart collections or the like, but I can roll back several versions for a test.

There are no errors in the console. This seems to be something specifically only impacting relationships; regardless if they’re table or smart view layouts.

Hi @David_Panzarella,

There is 2 different calls to to get this data:

  • One for the total records count (the one you’ve pointed here)
  • One for the records details of the current page

Here it would be very interesting to see this second call (payload sent and result received) to identify if the issue is coming from your agent or from the frontend.
This call should be a GET to an URL like
Can you identify it and show us its details?


Ok, I investigated as well.

Looks like the count result comes back (with >0 values) but the records call itself is not firing.

This is happening for all associated calls.

No errors in the console as well

@austinrupie thanks for your answer.

That’s very strange and inconvenient!
While we investigate, could you tell me when it started to not work please?

Hey @David_Panzarella and @austinrupie,

I might have an idea where the problem comes from. Could you please share the GET of the parent record, So here the GET of Wonder Works. It should be something like /forest/oragnizations/id-of-wonder-works. I need the payload, the attributes part can be omitted so you can share it here :wink:

Looks like it’s entirely missing the relationship data.

Yes you are missing the relationships links for pretty much all your relationships except Permissions.Did you change the serializer ?? Or override the routes ?

What’s odd is that Permissions doesn’t even show up in the list of relationships on the details page:

We’ve not changed our serializer or routes recently to my knowledge.

Most of our routes (70%) are not overwritten.

The ones that are have been working for 6 months and suddenly stopped last week.

Did you update your forest-express-sequelize package ?
Could you please give me the name of your project and on which environment it’s happening ?

No, we’re still running on the original setup:

 "meta": {
    "liana": "forest-express-sequelize",
    "liana_version": "7.12.4",
    "stack": {
      "database_type": "postgres",
      "engine": "nodejs",
      "engine_version": "17.9.0",
      "orm_version": "6.11.0"

The project is Rupie. Happens in both Production & Development environments

We need your team to investigate this asap. We’re moving too slow to resolve this and we’re incurring production downtime because of it.

I went back several merges and confirmed the same case. I know relationships worked fine then as some of those merges were directly related to Forest actions we were working on in dev and committed to production where they worked. Something is definitely off with our particular project, regardless of the environment.

I’m looking into it :eyes:

Hey @David_Panzarella and @austinrupie,

I see that you’ve made an upgrade from forest-express-sequelize@7.12.3 to forest-express-sequelize@7.12.4. This update upgrade forest-express@8.7.4 to forest-express@8.7.6. Which might introduce a regression in your case (cf: Comparing v8.7.4...v8.7.6 · ForestAdmin/forest-express · GitHub)

Could you please try to downgrade to 7.12.3 and tell me if that fixes your issue :thinking: ?