Smart action not available after pushing the code to production

Hello :wave:,

Feature(s) impacted

The smart actions

Observed behavior

I have created a functional smart action that works well well local environment

After pushing on the develop environment, I try to see on the develop environment what smart actions I have in my actions and I have it right

but strangely it is grayed out :confused:

I then tried to see in my local environment if it still worked, but it is also grayed out :confused:

Expected behavior

The smart action should work on the local and develop environment, but it is not the case


  • Project name: Nostrum Care v2
  • Team name: Operation
  • Environment name: Develop
  • Agent type & version: β€œforest-express-sequelize”: β€œ^8.0.0”

Would you have an idea ?:pray:
Thank you in advance.

Hello @jacques_liao,

I see that you are using our Roles feature. The smart actions are available by default in development but you need to configure who can trigger them in the production environment.

  • Did you update your roles to enable the smart action trigger?

Let me know if it helps.

Kind regards,

1 Like

Indeed I had not activated the smart action in the role.
Thank you @morganperre !

1 Like