Stripe action not showing sup

I have tried both methods to integrate Stripe into forest:

  • The stand-alone project, which works perfectly fine. I can see the actions as they should be.
    Screenshot 2021-04-28 at 10.18.08

  • Integration into the project (in dev environment for now):

	await Liana.init({
		configDir: path.join(__dirname, '../collections'),
		envSecret: process.env.FOREST_ENV_SECRET,
		authSecret: process.env.FOREST_AUTH_SECRET,
		integrations: {
			stripe: {
				apiKey: process.env.STRIPE_SECRET_KEY,
				mapping: 'users.stripeId',
				stripe: require('stripe')

which does display the data within the user’s details view:
Screenshot 2021-04-28 at 10.27.11

Expected behavior

To be able to refund clients with the ‘Refund’ action.

Actual behavior

The ‘Refund’ action does not appear in the Actions menu, only the following item is there:
Screenshot 2021-04-28 at 10.28.33

and when I click on a payment, i see the following view:


  • Package Version: forest-express-sequelize 7.6.3
  • Express Version: 4.17.1
  • Sequelize Version: 5.8.9
  • Database Dialect: postgres
  • Database Version: 12
  • Project Name: Kokoon.1

Hello @Adil_Niaz,

Really quick question, did you check if the smart actions are visible in your settings?
Plus, did you check if the access to the record is activated in your collection settings?

Thank you,


Thanks for the quick reply. Yes that was the problem. As The records were not visible on the left side menu, it did not occur to me to go through the layout editor to activate these options. it’s working fine now.

Thanks again.

1 Like