Actions not showing on local env

Hi,

When on a record, I want to perform smart actions.

At the moment, when I’m on a record an click action there is nothing there.
Capture d’écran 2020-10-21 à 12.16.11

I tried to refresh the cache as suggested here: HowTo fix Smart Actions disappeared from drop down but it still doesn’t fix the issue.

Context

Project Name : MyTraiteur

"meta": {
    "database_type": "mysql",
    "liana": "forest-express-sequelize",
    "liana_version": "6.3.13",
    "engine": "nodejs",
    "engine_version": "12.16.1",
    "framework": "other",
    "framework_version": null,
    "orm_version": "5.21.7"
  }

Hi @mathieuh !
Do you have any logs in your browser ?

Hi @Nicolas_Sailly,

Here’s what I get:

Mmh this doesn’t seem related to your problem. Did you update your liana recently ? Or did it stop working on it’s own ?

No I didn’t update it, it stop working on its own while I was working on one of the smart action.

So you were editing one of your smart actions ?
Do you have any logs on your Forestadmin server ?

No I don’t, nothing unusual…
I just noticed something weird though in the last schema.json generated.

-    "engine_version": "12.16.3",
-    "framework": "express",
-    "framework_version": "~4.17.1",
+    "engine_version": "12.16.1",
+    "framework": "other",
+    "framework_version": null,

Good catch ! That’s not normal indeed :thinking:
Are you using express ?
Are you using forest-express-sequelize or mongoose ? In which version ?
If you rollback to the previous version of your project (if you use git), do you still have the same issue ?

No it still doesn’t work if I rollback on the version used in production and the smart actions work fine in production.

{
  "name": "forest-v6",
  "version": "0.0.1",
  "private": true,
  "scripts": {
    "start": "node ./server.js"
  },
  "dependencies": {
    "chalk": "^2.4.1",
    "cookie-parser": "1.4.5",
    "cors": "2.8.5",
    "debug": "~4.1.1",
    "dotenv": "~6.1.0",
    "express": "~4.17.1",
    "express-jwt": "6.0.0",
    "forest-express-sequelize": "6.3.13",
    "sequelize": "~5.21.7"
  }
}

Even when I rollback to an old version I still don’t get the smart actions.
The schema.json seems right though:

"liana_version": "6.3.13",
     "engine": "nodejs",
     "engine_version": "12.16.1",
-    "framework": "other",
-    "framework_version": null,
+    "framework": "express",
+    "framework_version": "~4.17.1",
     "orm_version": "5.21.7"

Once you rolled back, can you try to empty your browser’s cache ?

Just did and still no actions :frowning:

I’ll try another browser just in case and let you know.

I came back on my last version (not the one that seems to have introduced the bug) and now the schema seems right even if my engine version is downgraded somehow:

     "liana": "forest-express-sequelize",
     "liana_version": "6.3.13",
     "engine": "nodejs",
-    "engine_version": "12.16.3",
+    "engine_version": "12.16.1",
     "framework": "express",
     "framework_version": "~4.17.1",
     "orm_version": "5.21.7"

Still no actions on other browser.

Are your smart actions set as visible ?

Are the smart actions present in your schema ?

I didn’t know about the switch “Make smart action visible”. It was off, turned it on, saved, still no actions.
Yes they are present in the schema.

One action just reappered. Maybe there is cache like on the switch?

Once you set them to visible can you try to refresh your browser again ?
Are they global, bulk or single actions ?

Ok they are all back, thank you!!
They are all single.
The native bulk action “export” as disapeared though.

Do you have any idea what could have set all smart actions to “not visible”?
About the bulk action “export” its not a big deal as I don’t need it in dev mode.