Supabase auto-increment is not imported into forest admin


I’m using forest admin cloud with my supabase project.

Feature(s) impacted

Create data

Observed behavior

The setup worked well but, I have an issue about importing auto-increment id.
On supabase, I have a simple table with :

As you can see, id is primary with auto-increment

But in forest admin cloud UI, when I want insert a data, I have

id is displayed as a mandatory field I need to fill. It’s weird. I have read one topic about a .forestadmin-schema.json which should be updated to force the auto-increment but I don’t find it in the ui and I have tried to use the cli to get the schema, update it and deploy it but I failed.

Expected behavior

The Id field should not be displayed

Hello @Olivier_Mattei,

Thank you for your feedback.

Can you try hiding the field id in the creation form on Forest Admin?

Hello again @Olivier_Mattei,

I tested on my own test database, with the exact same configuration (id detected as required). If you configure the form to hide this field, creation works as expected.

Hello @Olivier_Mattei,

We released a fix on this issue as it was specific to Supabase.

For it to be applied on your project, you can either refresh your admin panel with the button named “Sync database schema” on the bottom left side of the UI, or share your project name with me, and I’ll run it on my side.

Otherwise, the patch will be applied anyway when we’ll upgrade your install as we do frequently.

okay, I’ll do the test later today and let you know

It seems ok, I see Id field is optional. thx

1 Like