This chart cannot be rendered

Feature(s) impacted

Dashboard and charts

Observed behavior

Since I updated @forestadmin/agent to 1.4.1 and @forestadmin/datasource-sql to 1.1.4, on my dashboard, I get the error : This chart cannot be rendered. on every charts.

Expected behavior

Click on dashboard and see the graphics render correctly

Failure Logs

Chrome dev tool

Nest.js logs


  • Project name: meka-api
  • Team name: Op team
  • Environment name: Production & Development
  • Agent type & version: node-agent : “@forestadmin/agent”: “^1.4.1” running on NestJS 9.1.6
  • Update @forestadmin/agent to 1.4.1 and @forestadmin/datasource-sql to 1.1.4

Finally always the same error on the previous versions.

@forestadmin/agent: "^1.2.0",
@forestadmin/datasource-sql: "^1.1.1",

Hey @ThibaultWalterspiele :wave:

I’m currently unable to reproduce this issue on my end.
Do you have any specific configuration regarding your agent (renameField, etc.)

Thanks in advance

Yes I’ve this kind of specific configuration in order to add file upload field

Ok, but nothing related to the ExpeditionReport collection?

No but when I comment this code above, the error stops

1 Like

All the errors are triggering the exact same error message on the agent side?

I just checked your project configuration on my end and I can’t spot anything obvious at first sight (I can’t spot any chart configured that uses your video field, so I can’t really think of a reason that would happen).

Do you know if it’s the addField or the replaceFieldWriting that is causing this issue?

Thanks in advance

1 Like

Hi Jeff,

Seems like i’m exeriencing the same issue for the “this chart cannot be rendered”. Project is ExplorJob.
I’m logged in as admin, so i should be able to see them all. This bug started either :

  • when we moved to the paid version
  • when we upgraded forest-express-sequelize agent to version 9.0.0

The only charts that are still working are the one from Queries, but all the Simple ones are unvailable :

Any idea how i can have them appear again ?
I’m not a tech guy, so if you can help me with noob language, would be helpful :smiley:

Thanks a lot !

Hey @Nils_Guicherd :wave:

Could you please share both the request payload and response from any given chart that doesn’t work?
Thanks in advance.

sure, for instance, this is the most basic chart : user count

is this what you meant by “request payload and response” ? :thinking:

Hello @Nils_Guicherd,

To share the “request payload and response”, here is what you need to do:

  • right click on your browser and “inspect”
  • it opens the inspector, then navigate within to the “Network” tab
  • you should be able to see the failing requests (displayed in red?)
  • if you click on one of them, you will see then sub-tabs: here we want to see what’s displayed inside “payload” and “preview”

Can you share those with us please?

Other questions:

  • Is the issue happening on all of your teams?
  • How easy it is for your team to upgrade to forest-express-sequelize v 9.1.0?
  • And to downgrade to 8.5.14 just to see if it working?


1 Like

Here are the results :

For the very first graph : nb of users :

I can ask our external developper to change forest-express-sequelize settings (as it seems to be at the origin of the trouble) but at the same time, it was also this which enabled to have different roles, and we need them as well :-/
Plus she won’t be much available before mid january 'im afraid.

Hello @Nils_Guicherd,

Sorry for the delay! :christmas_tree:

I understand for the version rollback difficulties on forest-express-sequelize.
However, it would be great to upgrade your version to the latest (9.2.0 as of today), the issue might be fixed since then.
Let me know if this is something doable at some point.

For the logs you sent, unfortunately there are the ones I needed:

  • Open the inspector, then navigate within to the “Network” tab
  • you should be able to see the failing requests (displayed in red?)
  • if you click on one of them, you will see then sub-tabs: here we want to see what’s displayed inside “payload” and “preview

If you could send me those it will be easier to investigate!


my bad sorry. I’ll ask our partner to move to this new express sequelize then.

here are the views though :slight_smile:

and some paylods :


all previews answer are the same :


Thanks for your prompt reply.

Wait… I’m thinking about something trivial but needed to be double checked.
Does your role allow you to access to the collections used in the charts (users, messages, userReported, etc)?
You need to check which role is assigned to yourself and then check the permissions settings of that role (in the project settings).

Let me know!

sure, i’m admin

and here should be my permissions

it’s even more weird that i can actually see the charts made from “queries” but not “simple” ones.

Hello @Nils_Guicherd,

I went again over your use case and I could not figure out what’s going on exactly in your case :slightly_frowning_face:

Did you get the chance to make your external developper upgrade forest-express-sequelize package to the latest version?
If after doing it it’s still not working, we might need to jump on a debug session (with the external developper if possible).

Let me know and sorry again for the inconvenience.

thanks we’re good. the issue was only in production and not in local. The issue was because of our NodeJS which was not supported anymore, needed an update.
thanks for your support

1 Like