Forest Admin cannot render this chart for all Distribution dashboard charts

Hi, ever since we upgraded our application to support Forest v7 following Friday’s announcement, all Distribution (pie) charts on our dashboard are not displaying with the error “Forest Admin cannot render this chart”.

We are integrating via the Node.js forest-express package with sequelize & Postgres.

Looking at the Network tab, we are getting 403 Forbidden on the request to /forest/stats/[collection]. When we looked into the forest-express package, this is happening at the function _checkPermission(permissionName) in forest-express/src/middlewares/permission.js when _checkPermission('statWithParameters') is called.

This error occurs no matter which collection we set up the chart with. All other dashboard chart types are working fine (even against the same collection we used for the Distribution chart), so we are unsure why there should be any permission issues.

Any ideas on what might be causing this?

Expected behavior

Distribution charts should display correctly in Dashboard.

Actual behavior

Distribution charts not rendering with Forest Admin cannot render this chart error


  • Package Version: forest-express-sequelize 7.8.0
  • Express Version: forest-express 8.4.0
  • Sequelize Version: 4.42.0
  • Database Dialect: postgres
  • Database Version: 10.5
  • Project Name: Linkby

Hey @achak,

Sorry for the delayed reponse.

Does this issue appear on all your environments?
Could you share a screenshot of the configuration that fails in your case?

A change has been introduced recently around stats/charts permission. Could you also test the version 7.1.2 and tell me if you are experiencing the same behavior?

Thanks for your help :pray:

EDIT: I’m able to reproduce this issue with a chart using a related-data/relationships as a groupby. Rollbacking to 7.1.2 fixes the issue, however only the latest version will prevent the Chrome 92 issue.
Could you confirm you are in a similar case?

Hey @jeffladiray ,

I have just tried testing 7.1.2 and can confirm that it does solve the issue (I’m on Firefox 88.0.1 / Mac Big Sur 11.3).

Here’s a screenshot of a chart configuration that failed:

Basically grouped by a related data/relationship like you said and filtered by timestamp within the previous 365 days.

Hello @achak :wave:

I can confirm I’m able to reproduce. I have also open a ticket on our end for this specific issue. We will keep you updated once the issue is fixed.

Sorry for the inconvenience.

Thanks @jeffladiray , will wait to hear from you.

As feedback for the Forest team, we were quite disrupted by Friday’s “Upgrade Required” notice and had to scramble to get our application upgraded while our operational team was without software for the day. It mentioned remote & production environments were not affected, but in reality none of the Related Data panel of a collection was loading.

I’m not sure if we have had notices prior to that as unfortunately it was the only one that I received, so it was literally the first time we were made aware of it and had to rush through the docs.

I anticipate Forest plays a critical role to many operational teams around the globe, so just wanted to share the sentiment it would be great if we could have earlier notices, and also we would’ve expected more thorough testing prior to a major version rollout.

I do really appreciate the quick attention to this though and I’m glad we’re able to find out what’s causing the issue.


Hi @achak :wave:,

Thank you for sharing your concerns.

To be quite honest, we were also surprised and taken by time following the announcement of the changes of Google chrome.

The new version of Google Chrome (v92) - release in July - will no longer be compatible with development environments using the http protocol and using a version earlier than v7 (express) or v6 (rails).

However, you’ll be able to use all your remote environments using https on all previous versions of Forest Admin (no urgent need to update these environments). More info.

Be sure that we do our best to smooth the changes imposed to our customers given the criticality of our tools in their stack.

Sorry again for the inconvenience encountered on your charts during the upgrade, we’re on it.

Happy hacking!

1 Like

Thanks for the response @louis . As mentioned earlier we found that the Related Data panel within a collection row was suddenly not showing on our remote environments following Fri’s change (not development). I’m not sure if this was an unintended side effect of the rollout?

Hi @achak, this was for sure unintended. Is this issue persisting in your remote environments?

No it’s all working properly now after we upgraded to v7. The issue was prior to the upgrade on remote environments.

@louis Hi. I am having the same issues here. It seems to only happen with group-by on associated data/fields. This is happening for my remote and local development environments.

I am able to see the associated data (VimeoView => Company) on other parts of the admin panel such as the record details view, so the association seems to be configured properly.

forest-express-sequelize: 7.9.1
forest-express: 7.6.0
express: 4.17.1
Chrome: 90.0.4430.212 (Official Build) (x86_64) / Mac OS

Screen Shot 2021-05-18 at 2.09.42 PM

Hi @cto_nexus, can you please open a new thread datailling your issue and maybe linking yours to this one? I’m asking you this so that it’s easier for us at support to re-read the thread and understand your problem :pray:

Thanks a lot !

Hi, @lclisson thanks for the response. Someone from your team was able to troubleshoot this for me. Apparently there is something regarding Roles that needs to be “turn on” from your side.

Perfect and thanks for the heads up :slight_smile:

Hi @louis, just a quick check in to see if there’s any updates on this?

Hello @achak,

We recently release a patch on forest-express-sequelize 7.9.2.

Can you confirm that the issue has been fixed on your side ?

Thanks in advance. Really sorry for the inconvenience.

Kind regards,

1 Like

Hi @morganperre,

It seems to be working now after upgrading to 7.9.2. Thanks for your help!



Hi @achak,

Really happy to hear that has been fixed. :slight_smile:
Thank you for your time.