Unable to authenticate after installation on Rails

Expected behavior

Should be able to access Forest Admin dashboard when running App localy.

Actual behavior

I got the following error message :

Failure Logs

Here’s the logs of my Browser console :


I followed the Onboarding Rails Setup on Forest website, the installation went smoothly, but when I try to access the Forest Admin dashboard I got the “Unable to Authenticate” error message. I set the environment vars in my .env file (FOREST_ENV_SECRET; FOREST_AUTH_SECRET and FOREST_APPLICATION_URL=http://localhost:3000).
When I run rails s it goes to localhost:3000.

I tried to troubleshoot following solution on other thread with similar issues but nothing works.

I didn’t setup CORS on my side, but followed the documentation just in case (Configuring CORS headers - Documentation). It didn’t change anything unfortunately…

I’m running out of ideas here :sob:
Any help would be appreciated, thanks in advance !

  • Rails Version: 6.0.4
  • Project Name: Yumon

Hi @Walid_Benzina !
Do you use an ad blocker ? If yes can you try to whitelist Forest ?

1 Like

Nicolas you’re the best !!

My Brave browser blocked the website so it works now, that’s perfect :raised_hands:

Thank you very much for your help!

1 Like

Glad to hear that ! :slight_smile: