[Bug] Reference attribute in smart action field not finding related records

Feature(s) impacted

Smart Action with field having a reference attribute

Observed behavior

Reference field not finding related records so the form is never valid

Expected behavior

Reference field used to find related records, we noticed yesterday that it is no longer working.

Failure Logs


  • Project name:
  • Team name:
  • Environment name: All Environments
  • Agent type & version: forest_rails 7.7.0, Rails
  • Recent changes made on your end if any: upgrade from rails to
1 Like

Same issue here, server returns a eroor 500 on https://lenouvelespritpublic.herokuapp.com/forest/Podcast?timezone=Europe%2FParis&context[relationship]=BelongsTo&context[field]=podcast&context[collection]=Bada&context[recordId]=&fields[Podcast]=&page[number]=1&page[size]=100&search=3&searchExtended=0&searchToEdit=true

I typed “3” to find id of podcat 383 and ForestAdmin doesn’t find it

Hey @mjaidi @CoincoinNico

In your error message, it seems like you are using 7.8 (according to your console log), not 7.7.
Could you confirm the exact version you are using? (As well as sharing both your project name so I can check on my end what is going on?)

project: Okarito

indeed, i tried upgrading locally to see if it was fixed in the next version (7.8) so the error happened on both 7.7 (local, production envs) and 7.8 local env

@mjaidi @CoincoinNico, sorry the delayed response.

I just tried on my end and I’m currently not able to reproduce your issue.

Do you confirm that to are having this issue only on reference attribute in smart action fields ?

After more investigation, I’m able to reproduce as well.

I’m opening a ticket on our end for this issue to be fixed. Sorry for the inconvenience

Hello Everyone :wave:

We just released a fix, can you refresh your browser and confirm us that you get the desired behaviour on your smart actions ?

Thanks :slight_smile:


1 Like

Hell Steve !

Awesome I confirm that it works !

Amazing :slight_smile: