Can't generate a admin backend with Mongo DB Atlas

Feature(s) impacted

I’m trying to create a new project.
My steps :

  • selected Advanced setup
  • selected As a microservice
  • selected MongoDB Atlas
  • installed globally forest-cli@latest
  • logged in successfully
  • entered Connection URI (mongodb+srv://
  • execute the given command in the terminal

Observed behavior

The command to generate the admin backend (forest projects:create:nosql "trainease-app" --applicationHost "localhost" --applicationPort "3310" --language "javascript" --databaseConnectionURL "mongodb+srv://") failed with the response copied in “Failure Logs” section
I tried to run the command without :nosql but it failed too with the same response.

What did i miss ?

Expected behavior

The creation of the project

Failure Logs

 ›   Warning: projects:create:nosql is not a forest command.
Did you mean projects:create? [y/n]: y
× ["Cannot generate your project.","An unexpected error occurred. Please reach out for help in our Developers community ( or create a Github issue with following error:"]
Error: Unexpected arguments: --language, javascript
See more help with --help


  • Project name: trainease-app
  • Database type: MongoDB

Hey @Gwendoline, and welcome to our community :wave:

Could you share here the version of forest-cli you are using ? (forest --version should do the trick)

My guess is that you currently don’t have the latest version of the cli, preventing you to run this “new” command.

npm install -g forest-cli@latest should do the trick.

Let me know if that helps :pray:

Hi @jeffladiray,

Thanks for your fast response.

Here’s my version of 'forest-cli" : forest-cli/3.0.4 darwin-arm64 node-v18.14.0
I suppose it’s the last one because after running the command you gave me to install the last version, the version is the same. Can you confirm it’s the last one ?

Looks like the latest is the 3.4.0

Could you try manually upgrading to this version ?

I tried but my version seems stuck to forest-cli/3.0.4 darwin-arm64 node-v18.14.0.

Did I make a mistake with the command (npm install -g forest-cli@3.4.0 -s) ?
What can block the execution of the manual upgrade ? Can I force it ?

No error displayed in the console while running this command?

Could you make sure you don’t have multiple instances of forest-cli ?
Maybe a which forest would help locate the existing instance your using. Then you can process to remove + re-install, and it should work as expected.

Nop, no error displayed.

I try to to remove and re-install and let you know the result

1 Like

It worked !!

Thanks a lot !!

1 Like