Cant log in in forest-rails 7.0.0-beta.5

Expected behavior

I am able to log in with an email log in.

Actual behavior

When I use any version < 7 (I tried 3.3.0, 4.X, 5.X, 6.X. They were all incompatible)
api_1 | bundler: failed to load command: puma (/usr/local/bundle/bin/puma) api_1 | ! Unable to load application: TypeError: superclass mismatch for class Error api_1 | TypeError: superclass mismatch for class Error api_1 | /usr/local/bundle/gems/jsonapi-serializers-1.0.1/lib/jsonapi-serializers.rb:7:in <module:Serializer>' api_1 | /usr/local/bundle/gems/jsonapi-serializers-1.0.1/lib/jsonapi-serializers.rb:6:in <module:JSONAPI>' api_1 | /usr/local/bundle/gems/jsonapi-serializers-1.0.1/lib/jsonapi-serializers.rb:5:in <main>' api_1 | /usr/local/bundle/gems/bootsnap-1.7.3/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:in require' api_1 | /usr/local/bundle/gems/bootsnap-1.7.3/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:in block in require_with_bootsnap_lfi' api_1 | /usr/local/bundle/gems/bootsnap-1.7.3/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in register' api_1 | /usr/local/bundle/gems/bootsnap-1.7.3/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in require_with_bootsnap_lfi' api_1 | /usr/local/bundle/gems/bootsnap-1.7.3/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:31:in require' api_1 | /usr/local/bundle/gems/activesupport-6.1.3/lib/active_support/dependencies.rb:332:in block in require' api_1 | /usr/local/bundle/gems/activesupport-6.1.3/lib/active_support/dependencies.rb:299:in. load_dependency' api_1 | /usr/local/bundle/gems/activesupport-6.1.3/lib/active_support/dependencies.rb:332:in require' api_1 | /usr/local/bundle/gems/forest_liana-3.3.0/lib/forest_liana/engine.rb:2:in <main>'),

When I use version 7:

api_1 | (called from <top (required)> at /app/config/environment.rb:5) api_1 | * Listening on []( api_1 | Use Ctrl-C to stop api_1 | [ac73bada-fa18-4aa2-9c43-3ffc46492452] Started POST "/forest/sessions" for at 2021-07-15 21:25:19 +0000 api_1 | [ac73bada-fa18-4aa2-9c43-3ffc46492452] Cannot render console from! Allowed networks: [](, ::1 api_1 | [ac73bada-fa18-4aa2-9c43-3ffc46492452] **(1.8ms)** **SELECT "schema_migrations"."version" FROM "schema_migrations" ORDER BY "schema_migrations"."version" ASC** api_1 | [2021-07-15 21:25:19] Forest ![🌳](![🌳](![🌳]( No model found for collection sessions api_1 | [2021-07-15 21:25:19] Forest ![🌳](![🌳](![🌳]( Routing error: Resource not found for collection sessions. api_1 | [2021-07-15 21:25:19] Forest ![🌳](![🌳](![🌳]( If this is a Smart Collection, please ensure your Smart Collection routes are defined before the mounted ForestLiana::Engine? api_1 | [ac73bada-fa18-4aa2-9c43-3ffc46492452] Processing by ForestLiana::BaseController#route_not_found as */* api_1 | [ac73bada-fa18-4aa2-9c43-3ffc46492452] Parameters: {"email"=>"[redacted](mailto:redacted)", "password"=>"[FILTERED]", "token"=>"[FILTERED]", "twoFactorRegistration"=>false, "renderingId"=>"redacted", "projectId"=>"redacted", "collection"=>"sessions"} api_1 | [ac73bada-fa18-4aa2-9c43-3ffc46492452] Completed 404 Not Found in 572ms (ActiveRecord: 0.0ms | Allocations: 1061)

Failure Logs

Please include any relevant log snippets, if necessary.


Please provide any relevant information about your setup.

  • Package Version: 7.0.0-beta.5

I included a snapshot from the UI that is telling me my agent is out of date. I am not sure why it thinks that.

Hi @lordmaylor !
Did you follow the documentation when upgrading your version ?
Il you click on learn more you will have more information about the “out-of date” issue and how to resolve it (only for versions < 6).

The beta version is not supported yet and brings new breaking changes that are not documented yet. I strongly suggest that you use the last main version 6.6.2.

Ah, sorry i meant to include that versions <=6 are incompatible. I tried 6.6.2 already, and it doesn’t boot up due to the included mismatch Error (just reconfirmed).

I saw that 7.0.0 came out of beta today, but I am still running into the same error (2nd one). Also my UI is still telling me i’m using an out of date agent.

Also I didn’t upgrade any versions. I started a new account with a different gmail address from my work one and followed instructions to install. This project didn’t have Forest installed beforehand. v8/v7 was the first one that would allow Rails server to start, but I still can’t log in.

From your screenshot, I can tell there is a problem with the forest-rails version, you should not have to enter your password on v6+.
Cans you check in your gemfile ?

I duplicated the project into a different project, and it works now. (Still version 7.0.0). The original project is still returning the same Out of Date banner, but the newer project works. Thanks!

1 Like