Can't save changes in segments settings

I’m trying to save changes in segments and every time I click “Save changes” I get the following error message: Active investors11 update failed: Bad Request

It happens for every change I make in the segment (segment’s name, query, sorting etc.)

Hi @matt378,

I tried to reproduce but I’m not getting any 400 on segment creation/update (I might have missed something). Do you have any informations within the HTTP400 in your developer console > network?

Does this happen for all the segment or for this one specifically ?

Hi @jeffladiray

Attaching my developer console with the 400.
It happens on all segments and with every change I attempt to save

Hi @matt378

Can you please have a new try?
I don’t see any segments update that failed, in the last days.

Hi @Sliman_Medini

Still reproduce.

I tried with 2 different users and in different OS to make sure it’s not a personal user’s case.
The screenshot below is from 2 minutes ago. Can we set up a call so I can share my screen with you?

Hi again @matt378,

We are still investigating, we have questions:
-Can you please provide the entire payload of the failing PUT request? (you can eventually export an HAR by clicking on the request in the network tab)
-Are your problem only on segment update?
-Are all other layout edition ok? (collection visibility / order, field configuration, charts configuration…)

Hello there @Sliman_Medini

I hope I captured the correct thing since I’m not part of our development. If not, lmk and I’ll send it to our head of development to get you what you need.
re your questions:

  • It happens only on segments update. I successfully changed fields’ names, collection visibility and field configuration

Thanks for the answer.

No problem, unfortunately, this is not the request payload.
Request payload is accessible via the network tab in the screen you show.
The network tab contains the list of queries made against the server, and details for each of them.

Hi

I’m attaching the har file and a screenshot of the request payload. we can schedule a call if you need anything else.

Best,
Matan

(Attachment app.forestadmin.com.har is missing)

Hi @Sliman_Medini

Attaching the HAR file
app.forestadmin.com.har (64.1 KB)

Hi @matt378,

I’ve finally been able to reproduce your issue.

I made a ticket out of it and we’ll work on a fix asap.

Best regards

1 Like

Hi @matt378,

We just released a fix.

Feel free to come back to us if you’re facing any other trouble!

3 Likes

Hi @jeffladiray @lamatt_v @Sliman_Medini

Thank you for the fix!
Works now as a charm :slight_smile:

Best,
Matan

1 Like