Deactivate count response is returning 500 or 404

Feature(s) impacted

Hello, I’ve tried using the deactivate_count_response from https://docs.forestadmin.com/documentation/reference-guide/performance#disable-pagination-count. Unfortunately, I’ve encountered some problems (screenshot attached).

When I have the get in the routes.rb (get ‘/Patient/count’, to: ‘patient#count’ - also tried patients#count but also didn’t work), I get a 404 error and didn’t seem to have worked. I tried removing the get from the routes.rb file but it seems to still try calling the count function and gives 500 error.

Observed behavior

Still unable to provide search results using the search box even when record exists

Expected behavior

Speed up searching without timing out

Failure Logs

  • Attached screenshot

Context

  • Project name: Hint Health
  • Team name: Hint Health
  • Environment name: James Local
  • Agent type & version: Latest version
  • Recent changes made on your end if any: N/A

Hey @jong :wave:

Deactivating count query is a feature that was introduced in forest-rails@7.6.1. Looking at your project configuration on my end, the environment “James local” does not run a forest-rails version that is compatible with this feature.

Could you eventually try to upgrade and test again in your configuration?

Thanks in advance :pray:

1 Like