Error on smart action: Target records are out of scope


  • Project name: Clevermate dashboard
  • Environment name: test environment

I got the error “Target records are out of scope” while submitting on the smart action “Modifier prospect” edit-prospect. I got same error for some other smart actions for the same collection “prospects_list”

Do you get any idea about this please?

thank you.

Hello again @Adel_de_Clevermate !
It is difficult to give you an answer without a bit more context.

Can you please share a simple failing example of smart action implementation that will return the error ?
Is the collection a ‘smart collection’ ? Or based on a segment or some kind of filter ?

Thanks for your input,



hi @Nicolas.M

Here is a screenshot of the error shown once I submit the smart action.
I will DM the implementation of that smart action as well.
the collection is a normal collection, its model correspond to a VIEW on the DB (postgres).

Hi @Adel_de_Clevermate ,

Thanks for your input. I have indeed received the details via DM. I am looking through them and will get back to you ASAP.


I have successfully tested your code on my side, without any errors.
However, I have noted that the error message that you get is a result of trying to update or view a record that is out of scope of your permissions. Can you please ensure that all the records that you tried to updade with the given smart action are available to the caller profile ?


I think that the issue was with the permission of function associated with that smart action. Looks like with a collection imported from sql VEW we are allowed only to read data from it.

1 Like

Hello @Adel_de_Clevermate ,

Thanks for reporting back on your issue !

Have a nice week.

1 Like