Forest Admin folder not created on postgres and docker setup

This is a template you can use to report issues. You can also drag images, videos and include Preformatted text

docker pull forestadmin/lumber
docker run \
-v `pwd`:/usr/src/app --init \
-e DATABASE_SCHEMA="public" \
-e DATABASE_URL="postgres://app:app@host.docker.internal:5432/app" \
-e DATABASE_SSL="false" \
-e APPLICATION_HOST="localhost" \
-ti forestadmin/lumber

Expected behaviour

After running the above command runs successfully. I expect a folder to be created in my current working directory as stated in the docs(Install in Lumber - Documentation), but instead, the folder can’t be found.

Actual behaviour

The commands run successfully but don’t create a folder to get my credentials

Failure Logs


Hey @adebayoileri, and welcome to our community :wave:

I just did a quick test on my end, and I’m unable to reproduce. On my end, a folder is created, just like in the documentation.
I can actually see the

-v `pwd`:/usr/src/app --init

So I can’t really think of any specific reason you would not have the generated folder.

What is the OS you are using? And your docker version?

Just in case that might unlock the situation, our lumber based installation would also generate a docker-compose.yml, allowing you to also run your generated backend from docker

Thanks in advance.

Thanks for helping out @jeffladiray

I use a Windows 10 Home OS and Docker version v20.10.6.

I’m unable to use the lumber setup cause I am trying to set up an already existing project locally.

@adebayoileri I may have missed something here. You already have an existing lumber application you want to setup on your local machine?

If that’s right, you just need to:

  • Retrieve the .env file of a running project
  • Create a new Development environment (From your project settings > Environments) & replace the value of FOREST_ENV_SECRET by the one provided on your screen
  • Start your project, running either docker (Using the existing docker-compose file) or npm|yarn start

Yes @jeffladiray I have an existing application to setup, But I don’t have the option of creating a new development environment on the project dashboard


Could you share your project name so I can check on our end?

Hi @jeffladiray, thanks for helping out.
Unfortunately, I can’t share the project name. Let me know if can assist in any other way.

Could you share it privately (Discourse support direct messages)?
If not, I’ll not be able to check your project configuration on our end.

Are you an administrator of the project? If not, I would suggest to ask the administrator to create a new development environment for you and share to you the environment secret.