Forest Admin Freezes when uploading content

Hello, I just tried to upload some PDF files on two different project through forest admin, but it freezes when you upload a file on these screen :

It works for images, and it’s not a size problem, the maximum size has been incremented to 1000mb. It doesn’t work for videos also. Yet, in the select field, there are no file restrictions set.

Any Idea of what it could be ? there are no errors in the console when this happens, just a request to forest admin servers and no answer after that

Hello @bricemacias,

Thanks for your message and welcome to our community! :raised_hands:

That is strange, it is working fine on my side.

On what browser are you trying?

Did you try with another PDF file?
If it is not confidential, could you share the incriminated file with me?

Thanks.

Hello @adriguy,

I tried in Safari, Chrome and Firefox, and it’s the same.

One thing to know is that we are not using S3, we are uploading directly on the server with file system. Another thing to know is that it was working fine, and now it’s not.

I tried with many different pdf files, it’s still the same. With every video also.

For images on the other hand, it works…

I cannot upload pdf files here but I can send it to you by other means if you want

I have the same problem, I am uploading to S3 using a fresh project and almost cut and paste of the code from the documentation.

Images seem to work fine but some pdfs do not.

I would be happy to share the pdf in question but this forum does not accept pdf as an attachment type

@bricemacias @PitchlabsAsh,

Thanks for having shared your PDF examples with me.

Unfortunately, I was not able to reproduce the issue yet :confused: But there is obviously something going on!
Let’s try to make it working at least on Chrome first.

@bricemacias in your use case, you are trying to upload the document in a record creation, correct?
@PitchlabsAsh if I understand your message here, your use case is when you try to upload a document in a smart action form, is that it?

Could you guys give me your Chrome version? :pray:

Thanks.

Hey @adriguy,

Indeed, we do it in a record creation. It also fails when updating.

my Chrome version is : Version 96.0.4664.93 (Build officiel) (x86_64) (Mac)

We really don’t understand why it works with (heavier) images, but freezes with videos and pdfs…

@bricemacias,

I just tried with the exact same Chrome version than yours, your PDF document, but still no luck, it worked :exploding_head:

Could you please share the edit widget settings of your field?

Thanks again!

@adriguy

I just tried again, it still freezes :disappointed:

What we don’t understand either is that it was working before, and then it just started freezing like this, but we didn’t really change anything in the code in the meantime…

@bricemacias,

Could you try with an incognito window?
This way, you should not have any extension activated…

@adriguy

Just tried, still the same :confused:

@bricemacias,

Sorry I am still stuck, the issue remains not reproducible for me :exploding_head:

Are you using a Mac or a Windows OS?

As I still can’t have the issue on my side, I was wondering if the problem could be more global, not only due to Forest Admin services.
Do you know if you encounter browser frozen issue when uploading a file on some other web services?
I just googled browser freezes when uploading files and it seems that some global issues could exist…

Let me know.
Thanks!

@bricemacias any news on this topic?