Forest Admin Website Locks up with no expanation or way to fix the problems!

Hello Forest Admin Community!

I am using hands on the product for the first time to generate a test of the product admin using a big MySQL database with a slightly more complicated database schema than most.

The problem is the cli client / server software says Successfully mounted on Standalone server ( but it does not respond from the website or browser under my public ip’s port 3310 at all. I have no firewall so it must be an application configuration error. Please help I really want to try your impressive software stack successfully.

Feature(s) impacted

Installation Process Stops Without User Education on Website and CLI Tools.

Observed behavior

My problem today is the cli client stopped producing output and the website stopped advancing waiting on the server to connect to the website

Expected behavior

I would have expected more information like a time counter saying how long to expect the cli or website to complete the connection and what to check if the process stalls or freezes in some way.

Failure Logs

npm run start:watch

7x@0.0.1 start:watch
nodemon ./index.js

[nodemon] 2.0.22
[nodemon] to restart at any time, enter rs
[nodemon] watching path(s): .
[nodemon] watching extensions: js,mjs,json
[nodemon] starting node ./index.js
info: Schema was not updated since last run (hash: bd09411a917ae0610dfb1d4ef0820af96fbf64f0)
info: Successfully mounted on Standalone server (


  • Project name: 7x
  • Team name: Graham Brookins
  • Environment name: Ubuntu 24.04
  • Agent technology: php / nodejs
  • Agent (forest package) name & version: Latest; Provided by website at installation time.
  • Database type: Mysql
  • Recent changes made on your end if any: None just default LAMP Installation. No errors durring the entire installation process. That said no warnings or explanation when I run the npm run start:watch and the process fails to connect to the website. The website says, “waiting for backend to run” but never advances regardless of time waited.

I’m at a loss but can follow technical directions easily please tell me where to try to fix this problem so I can try your product.

Thanks in advance,



You’re almost there, sorry for the inconvenience. All seems to be good.

What is your browser? We encounter an issue with brave (thread). If you’re using Brave, can you try another browser? If you use extensions that may block http requests, can you try disabling them?

Tell me if you are still blocked :pray:

1 Like

Hello Alban,

First thank you for your reply. I am not using brave but trying to use Firefox/Chrome with No Script (now disabled completely) or even safari but sadly I now have a new different error after trying again in Chrome without NoScript or other extensions that could cause problems with your software.

I get a new error now upon loading the website project in a vanila safari intallation on desktop,


Agent unreachable

Forest Admin can’t reach your server. Please restart it, and if the error persists, refer to our community forum, or read the documentation.

Log in again

Back to projects listarrow_back


I also tried restarting the watch command from scratch but it didn’t change.

Edit: I also wanted to say i’m hosting the server on AWS and added incoming tcp port 3310 incoming traffic through their unique firewall configurator. But this changed nothing in my testing with Safari. Are their other ports I need to open up?

I’m again at a loss as to what to do next. Please advise as I am eager to try the product further. I love your slick toolset working together as one product. I just can’t seem to understand the error.



To simplify things, you can run your server on your development environment to test our product locally on your localhost. Additionally, you can use the cloud onboarding by connecting to an online database, which is the standard workflow. Once that’s done, you can deploy your server (not using the cloud onboarding method). You can read this documentation, it is more specific to AWS.

As mentioned, Forest Admin can’t reach your server, likely because your server is not accessible from the internet. Can you access it from your browser?

In summary, Forest Admin can connect to your server if it is either on your localhost or accessible via the internet.


1 Like

Yes the server is our primary production webserver it hosts our company website :confused:

Can you try our product on your localhost or in the cloud by using an online database ?

I am sorry I thought I was … I don’t know what you mean online database. I’m using AWS for my cloud hosting. My production server hosts the database but it is not exposed to the web.

How can you help your onboarding?
Did you try to follow the documentation to onboard with AWS?

I don’t know what you mean online database

In cloud, forestadmin host a server for you, it will connect to your database. The database must be available on public internet to speak with forestadmin.