Forest auth issue with Rails version v6.6.3

Like other people, following the SSL issue from yesterday, we have been unabled to log in.

The customer success service told us to create a thread here. We have bump to v6.6.3 but it is still not working?

Error: [{“status”:400,“detail”:“Invalid client id”,“meta”:{},“name”:“InvalidClientIdError”}]}
Can you help please?
Thank you.

Hello @Delphine_Vilaysack,

Thanks for your feedback.

Just to be sure, are you using a static FOREST_CLIENT_ID on your environment?

If it is not the case, you need to clear the cache of your rails server, because the previous client id is now invalid and it is persisted in the application’s cache.

If you are using a FOREST_CLIENT_ID, you will need to generate a new one, following this documentation.

We are not using FOREST_CLIENT_ID.

We cannot clear the cache of our rails server because we might lose jobs on Sidekiq or stuff.
When looking at the keys in our cache we only have [“cache:”].

You need to clear this value

Yes that’s what we did. Thanks.

@Delphine_Vilaysack Did it work on your end?

I had the same issue, running ‘bundle exec rake tmp:cache:clear’ worked for me.