Forest-cli fails to run

I have been trying to use the toolbelt project (forest-cli) to apply schema as part of the CI/CD process.
It seems like the toolbelt fails to run.

Expected behavior

Toolbelt runs as expected.

Actual behavior

The toolbelt does not run properly.

Failure Logs

The following error is produced:

(node:69867) [MODULE_NOT_FOUND] Error Plugin: forest-cli: Cannot find module 'globby'
module: @oclif/config@1.8.8
task: not loading commands, globby not found
plugin: forest-cli
root: /Users/myuser/.nvm/versions/node/v8.11.1/lib/node_modules/forest-cli
See more details with DEBUG=*
The Lumberjacks' toolbelt is the Forest CLI which makes easy to manage your back office application directly from the terminal.

  forest-cli/1.4.1 darwin-x64 node-v8.11.1

  $ forest [COMMAND]

  help  display help for forest


Please provide any relevant information about your setup.

  • Package Version: forest-cli/1.4.1
  • Node Version: 8.11.1
  • OS: Tried on max osx and windows

Seems like this problem is due to not including the /oclif.manifest.json in the output of the bundle like described here.

Hi @Yoad_Snapir !
I can reproduce your error on my end, thanks for the link to the issue !
I will create a ticket to fix this bug, in the meantime you can go to the forest-cli installation folder and edit the package.json like so:

  "files": [


 "files": [

It should fix the error :slight_smile:

Here is the ticket :slight_smile:

You mean edit the package itself before installing? Or actually editing in the installation destination (under node_modules).
Since I tried the latter and it did not work…

You can update it and run yarn --force to reinstall the packages :slight_smile:

Nah, not working for me - but I will just wait for any fix on this. Anyway cannot have this hack in my live deployment CI/CD.
Thanks for looking into this!

1 Like

Hi @Yoad_Snapir,

You can also use forest-cli@1.2.0.
It does not have the regression and offer the exact same features so far.

@Yoad_Snapir Everything should be working now :slight_smile:
You can use npm i -g forest-cli to update to the latest version !

For the record, this issue has been patched in forest-cli@1.5.1

All good guys! Thanks for the prompt fix!