Forest UI Authentication - V7

Hi Forest,

I have implemented the V7 authentication config. When I load Forest UI, it sometimes authenticated me automatically and sometimes does not.

When it does not, I displays

image

But I have nothing in the log saying something is wrong.

Can you help me?

I can see this error in console:

@louis I regenerated the FOREST_CLIENT_ID and it worked again.

How often should we regenerate it? Why don’t we have a clearer message telling us to regenerate it?

Is’n it a problem in prod if we have to regenerate the environment variable regularly ?

Hello @Guiguijo,

You don’t need to configure FOREST_CLIENT_ID if you only have one instance running.

Kind regards,
Morgan

Hi @morganperre ,

I have several instance running in prod.

But anyway, it should work with a FOREST_CLIENT_ID even with only one instance in dev, shouldn’ it ?

Hello @Guiguijo,

I’m happy to hear that it works again on your production server. You are not supposed to change your FOREST_CLIENT_ID once set as an environment variable so it should work great. :slight_smile:

If you want me to investigate a bit more on your issue can you try to see the logs from the route /forest/authentication on your server side and share it to me?

Kind regards,
Louis

Hi @lclisson ,

I had the issue on my dev environment. I was just answering to @morganperre that I we have multiple instances on prod. That’s why we use FOREST_CLIENT_ID.

Anyway, the thing is that I had no log on server side. Forest was enable to reach any /forest/authentication root … but did not either raise a 404 or something. The logs were juste saying that Forest was available on port …

According to your console logs it looks like the issue came from your certificate. Did you modify anything on it? Can you connect to ForestAdmin as expected?

I did not change anything on the certificate. I was just working as usual.

After regenerating the FOREST_CLIENT_ID for my dev environment I could connect to ForestAdmin.

After investigation I was able to identify the origin of the problem and it comes from the setup of a development environment under HTTPS which requires the acceptance of the certificate (hence the error in console). To solve this problem you just have to open the url and accept the conditions issued by chrome.

Thanks @lclisson . I will do that