Issues installing on Rails app, "Waiting for backend to run"

I am wanting to install forest as a new admin dashboard on my Rails app.
After following all of the steps, it is stuck on “Waiting for backend to run”.

Originally I thought it might be an issue with my previous Rails Admin gem that I had installed and so I made sure that all files and code for that were indeed deleted. I also tried to completely remove the Blazer gem just in case that was something. Nothing.

I then upgraded Ruby from 2.6.6 to 2.7.3 to see if that was an issue. Still nothing.

Next, I created a whole new App from an Airbnb template and installed Forest in the same way but still hitting the same problem.

I also tried logging in from the page but that also shows the error as shown bellow.

I also tried the rake forest:send_apimap as posted in another similar case but still having the issue.

Secrets.yml looks correct to me.

Failure Logs

Hello @ArcticFox ! :wave: Welcome to our community :tada: :confetti_ball:

I’m not able to reproduce your issue. Everything is smooth during the rails In-App onboarding on my side.

Are you sure the forest_env_secret, forest_auth_secret and forest_application_url are well defined in your config/secrets.yml ? (Normally it should be done automatically)

Can you also give us your forest_liana version ?

Thanks in advance


I have forest_liana 6.3.2 installed.

And for the secrets.yml file I have on my airbnb tester app

forest_env_secret: cc861b030*********
forest_auth_secret: vqWA2B*********
forest_application_url: http://localhost:3000
forest_env_secret: <%= ENV[“FOREST_ENV_SECRET”] %>
forest_auth_secret: <%= ENV[“FOREST_AUTH_SECRET”] %>
forest_application_url: <%= ENV[“FOREST_APPLICATION_URL”] %>
forest_env_secret: <%= ENV[“FOREST_ENV_SECRET”] %>
forest_auth_secret: <%= ENV[“FOREST_AUTH_SECRET”] %>
forest_application_url: <%= ENV[“FOREST_APPLICATION_URL”] %>

Here is a Network log if that helps

Ok. All clear to me.

Can you create a new project on ForestAdmin. You will restart a new Rails-InApp Onboarding but keep the same rails project (your airbnb tester app).

First thing first, cut your current Rails server instance.

Then, during the onboarding you will run the command:
rails g forest_liana:install bcbe6XXXXX

You should have the following message :

Forest liana already installed on this app.
Here is your current environment secret: 80eXXXX
You can update the config/secrets.yml file with the new environment secret: cd1e777f92a0743XXX

Just update the forest_env_secret in the secrets.yml. Then run your server rails server.

Let me know if this time you’re still stuck.

I have updated the env_secret with the new one provided in the console but it is still not connecting to Forest.

Thanks for your patience. Clearly, it’s not related to your setup.

Have you an AdBlockers or a similar extension ?

I see an error net::ERR_BLOCKED_BY_CLIENT for each call to the agent. The following StackOverflow thread explains that those extension can block requests…

Let me know if it help.


Ah You’re right!

I am not running an AdBlocker but I am using the Brave Browser which has an integrated Adblocker.

After logging in to the site on Safari, it went through successfully.

Thank you Morgan

p.s. I lowered the Brave Shield for and it now logs in with no problem :slight_smile:

1 Like

Really great news. I’m relieved that we found a solution. :smiley:

Have a nice day.

1 Like