Stuck on "Waiting for your backend to run..."

Expected behavior

After succesfully launching the Generate a new backend application command with no errors and launching succesfully npm start with backend showing and returning :
GET /forest 204 - - 1.657 ms
GET /forest 204 - - 0.850 ms
GET /forest 204 - - 0.654 ms
GET /forest 204 - - 0.736 ms
GET /forest 204 - - 1.007 ms
GET /forest 204 - - 1.275 ms

Forest Admin UI should then go to another state than ’ Waiting for your backend to run’

Actual behavior

The UI is stuck on Waiting for your backend to run

Failure Logs

No error logs, neither on the install, nor on local backend on my MBP, nor on console in Forest Admin UI, and on the Network tab, requests are successfull with 204 all over the place, yet still launching them infinitly.
The only error logs, which I think are irrelevant in console are those :


  • Package Version: Lumber 6.14.4
  • Express Version: 6.14.4
  • Sequelize Version: 6.14.4
  • Database Dialect: Postgres
  • Database Version: 9.6.20
  • Project Name: Zimmer Backend

I managed to get to the pannel, now I’ve managed to get the production quite deployed, by the way, when we add what is given in the process as ENV var, it fails in the console, we need to add “” to the ENV vars, so instead of :

I had to write :
export FOREST_ENV_SECRET=“xxxxxx”
export FOREST_AUTH_SECRET=“xxxxxx”
export DATABASE_URL=“xx://
export NODE_ENV=“production”

Now I have 2 issues :

  1. I have created roles, assigned users to them, copied the layout from dev to prod, yet I can only see this and no Production environment although my backend is up and running with no error logs :

  2. When I try to update a table (on dev environment bc of issue n°1) that is called td_media or any table that has a relationship to this table (for exemple Object linked to it through a ObjectsMedias table), I get an error. The reasons seems to be that Forest Admin try to find a table with the singular or Media, which is Medium (and I have no medium table anywhere) :

It’s searching for forest-ta-objects-medium which is interesting as it doesn’t try to put “Objects” to it singular form, it only tries to transform Medias → medium (btw, Media is the plural of Medium, not MediaS)

Have a nice day !

Hello @Pierre_Gerbaud and welcome on our community forum !

1/ Thanks for the clear informations you’ve just provided. Can you tell me if you see your environment accessible from the role you’r assigned by going to your project’s settings page → role section?

2/ If I understand well your issue, you’ve updated your database structure and modify your model in your forestadmin app and the relations are not well set?


Hello Louis, thank you for your answer !

1/ Yes I can see my role (Admin) has the right to access and edit the production environment and its tables.

2/ I didn’t update anything, it’s a behavior from a fresh install, and I didn’t change my database structure neither from forestadmin app or anywhere else since the install of forestadmin. And I never had any table named “medium” or including “medium” in it. So my guess is the forest-ta-objects-medium should probably be forest-ta-objects-medias, and I believe lumber or forestadmin guesses it’s plural and should go to singular ? (And I can’t see any reference to medium in the auto generated files in my backend)


1/ Can you give me your project name so I can try to check if everything is good on our end?

2/ I’m not sure to understand what your problem is. :confused:
Why do you want to update the table name? Does the one from the fresh install work? If yes I suppose that if you want to change the name your would have to change it at every place where the code is impacted. :slight_smile:

1/ Sure, the project is named

2/ I don’t want to update the table name, I want to add line to the table Medias using forest admin (not a field, a line), or just use and add lines in any table that is linked to Medias table or any table containing “Medias” in its name (which are those that doesn’t work and display the same kind of error).
No a fresh install does not work, with a fresh install I can’t add any line in my database using forest admin (I can of course from postgres), and I’m getting the kind of error in the console you can see on the screenshot above. And I believe it’s a frontend issue with the name of the table being translated to singular when it shouldn’t. Neither in the UI, in the database or in the backend, there is any reference whatsoever to anything containing “medium”. Yet it’s a table supposedly named with “medium” that forest can’t find in the error displayed in the console (which is the singular of Medias in latin)

1/ I think I manage to understand what is going wrong in your case. You created a role but there is no user assigned to it. So I suppose that you should go to your project’s settings pages → user section → click on your user and give it the admin’s role you’ve created and then you should be able to see your production environment.

2/ Ok so can you show me the network request that failed with the response error from the network tab of your browser dev tool ? :slight_smile:


1/ Oh okay, perfect thanks ! In the list of users, it was displayed my user with “Admin” alongside it, but it’s not mentioned that this was the user permission and not the role. And where the role should stand, it was just blank so I didn’t notice a field wasn’t assigned, maybe an italic grey “no role” would have helped me understand that, but that was definitely not a bug as it’s working now, thank for your time on this one.

2/ There’s no network error (actually nothing is fired when this error appear after a click on “Create” of any table linked to something called “media”), only a console error I shared here (which is why I believe this one is a front issue), I can share another one :


I think I understand your issue and to help you I will need to reproduce on my end so I can debug it for you. Could you please share me a SQL dump of the table that lead to this issue?


Can I send it to you on a mail ?

And by the way, I tried a new fresh install this morning, and I’m still stuck on “Waiting for your backend…” I tried hard refresh, it doesn’t change, my local backend is responding to the forest calls with 204, there are no error logs on the server, nor on console, nor on network.

The project is listed in my projects list, but when I click on it I get “Access forbidden” and on the role page I get “You cannot create a role until your project has been deployed remotely.”

I waited for a bit, refreshed multiple times and then I could create roles. When I created a role it displayed “Production or remote environments cannot be found”, yet the role was created, I assigned it to me, but it didn’t change the “Access forbidden” when trying to access my project.

The last time it resolves itself after some time, I’ll see if it does the same way this time.

Hello @Pierre_Gerbaud,

For the production environment issue let’s try to understand what is going on.

Could you please go to the Project settings → Environments → CLick on production and confirm that there is no message This environment is not yet configured on your <...> server.

Also on the production server can you please confirm that you have a .forestadmin-schema.json file?

For your second issue, we did not receive your SAL dump. Could you please share it (in a private message here)? Plus can you check in /models folder that your models and relationships are correctly defined with correct names?

Thank you