Layout update not saved

Hi! I have some unexpected behavior that suddenly showed up in some fresh project I set up today. For the record, I was able to have some layout configuration done before this issue appeared.

Expected behavior

When I change my layout, the changes should be persistent

Actual behavior

I can update my layout properly (even get the success message), when leaving the edit mode I can see my changes (for instance, let’s say I made a collection visible, when going back to the classic non-edit mode, I can go and check the said collection).
When refreshing the page though, all the changes are reverted, may it be a field renaming, a collection / smart action / segment update.

If I refresh the page while being on the collection I just made visible, I get this error screen :

Here are a couple of screenshots for better understanding :
Untuched stat, before any update :

I make some collections visible, then leave the edit mode (at this point, I can see the collections and their records):

After I refresh the page : back to square one (with the error screen as mentioned if I was monitoring one of the disapearing collections)

Failure Logs

I have two errors logged in the console :
GET 404

Uncaught DOMException: Failed to execute ‘measure’ on ‘Performance’: The mark ‘start widget::load’ does not exist.

These two errors show on page refresh, wether I edited something or not.
Nothing shows on server logs


“forest-express-sequelize”: “^6.0.0”,
“forest-express”: “^7.4.0”,
“sequelize”: “~5.15.1”,
“express”: “~4.16.3”,
“dotenv”: “~6.1.0”,

Hi @jcastagne,

We have observed some technical queueing in the 3 previous hours.
It now looks ok.

I cannot reproduce the issue on my end.
Do you still experience this right now?

Thanks for your help.


Thanks for your reply, we just saw that it worked as of now, and i came by to report here when I saw your answer.
Problem solved, not an actual issue then. Should I delete the post?

1 Like

Hello @jcastagne, thanks for letting us know that everything is fine now.

No need to delete this thread. I just marked an answer as the solution of your issue. It marks the whole thread as solved.

1 Like