One more layout refresh problem again

Hi team,

It seems that we have a new layout refresh problem this morning.
My new layout does not take into account the last changes.

Could you please manually refresh our following environments:

  • Development
  • Staging

Thanks in advance

    "database_type": "postgres",
    "liana": "forest-express-sequelize",
    "liana_version": "6.6.3",
    "engine": "nodejs",
    "engine_version": "12.13.1",
    "orm_version": "5.22.3"

Hi Louis-Marie,

Sad to listen to this.
Can you please explain how do you point to a ‘layout refresh problem’?
And please, what is the name of your project?


Hi @Sliman_Medini

I have a collection users on which I have modified the smart action named mail request user action

On this smart action, I have added two new values to the Enum field named: Mail_template

Result: The new values do not appear in my environments.

Since this morning, I have restarted my local development server, now they appear.
But it is still not the case in my Staging environment.

This is clearly a recurring problem.
Could you please refresh it manually?

I am adding that these new values appear in my .forestadmin-schema.json file

Thanks in advance

In order to assist if necessary, my Staging server has been restarted with the changes at
17 Mar 2021 10:15:43 GMT


Hi team,

Could someone help me please and refresh our Staging environment layout?

We need it to complete some tests and we are blocked since this morning.

Thanks in advance for your help.

Hi again @Louis-Marie,

I’ve triggered a layout refresh.

Hi @Sliman_Medini

I am sorry, but the layout is still not refreshed.

Could you please have a look at this ticket:
Layout refresh problem again - #21 by Louis-Marie

It might give you some tips.


Is your project named ‘MyPocket’?


Yes, this is our project’s name. MyPocket


Can you please confirm you do not see the new enum on your staging now.
Also, con you please provide the enum values that are missing?

I currently see 6 values:



The two new values do not appear yet.
It should have 8 values.

The two last ones do not appear (while they appear now in Development environment)

The missing values are:



On our side, the last update date for your staging environment seems to be is 01/03/2021 17:17:22.

It means the ‘refresh layout’ is triggered with an old copy of the apimap (.forestadmin-schema.json).
Please restart your staging to have it synchronized again.

I have already restarted it once in the beginning of the afternoon without success.

Now, I have integrated other changes: two new columns in the kyc collection.
They appear in Development environment.

I have restarted again the Staging environment.
And now, all my previous changes appear.

I can’t explain why the problem was persisting and why you did not received the last update date this morning…
This is really annoying.

However, for now, my problem is solved. Hoping this will not reproduce.

Thanks for your help.

1 Like