Smart actions orders on the new UI

Hello,

With your new UI, how do we do to change the smart actions display order now ? On the previous UI, we were able to see the “Action” button, from a table view, in the layout editor. And by clicking this “Actions” button, we were able to drag and drop smart actions up and down to change their order.

Many thanks for your help.
Regards,

Hello @Guillaume_Laganier,

I just try and I’m able to drag and drop actions.
Screenshot 2021-05-28 at 14.27.01

Can you share your project name ? So we can check any problems on our side ?

Best regards,
Morgan

1 Like

Hello Morgan,

Yes that’s what I used to do too, but I can’t anymore.

Project name : Production

here is an example of. what I see on my users table :

Cheers,

Hi @Guillaume_Laganier,

Could you check that the smart actions appears in your collection settings (the small cog next to your Users collection)? And that they are made visible (the small toggle on it)

Cheers,

Hello Valentin,

Yes they are all visible. And that’s why it’s the anarchy. They are in the wrong order, and on some tables we have more than 15 smart actions. I really need to re order them.

Cheers.

If I understand well, your actions are properly displayed on both the collections settings and the collection itself but triggering the layout editor does not display the orange actions button that allows to reorder those action right?

If so, could open your browser console and check for console error while enabling the layout editor mode?

Exactly !

Sure, here is what I have in the console :

text here :

Uncaught DOMException: Blocked a frame with origin “https://js.driftt.com” from accessing a cross-origin frame.
at new Ee (chrome-extension://gccahjgcckaemgpliioopngfgdaceffo/js/contentScript.bundle.js:1:854516)
at new je (chrome-extension://gccahjgcckaemgpliioopngfgdaceffo/js/contentScript.bundle.js:1:857874)
at new Nn (chrome-extension://gccahjgcckaemgpliioopngfgdaceffo/js/contentScript.bundle.js:1:959359)
at Module. (chrome-extension://gccahjgcckaemgpliioopngfgdaceffo/js/contentScript.bundle.js:1:986876)
at n (chrome-extension://gccahjgcckaemgpliioopngfgdaceffo/js/contentScript.bundle.js:1:110)
at chrome-extension://gccahjgcckaemgpliioopngfgdaceffo/js/contentScript.bundle.js:1:902
at chrome-extension://gccahjgcckaemgpliioopngfgdaceffo/js/contentScript.bundle.js:1:913
contentScript.bundle.js:1 Uncaught DOMException: Blocked a frame with origin “https://js.driftt.com” from accessing a cross-origin frame.
at new Ee (chrome-extension://gccahjgcckaemgpliioopngfgdaceffo/js/contentScript.bundle.js:1:854516)
at new je (chrome-extension://gccahjgcckaemgpliioopngfgdaceffo/js/contentScript.bundle.js:1:857874)
at new Nn (chrome-extension://gccahjgcckaemgpliioopngfgdaceffo/js/contentScript.bundle.js:1:959359)
at Module. (chrome-extension://gccahjgcckaemgpliioopngfgdaceffo/js/contentScript.bundle.js:1:986876)
at n (chrome-extension://gccahjgcckaemgpliioopngfgdaceffo/js/contentScript.bundle.js:1:110)
at chrome-extension://gccahjgcckaemgpliioopngfgdaceffo/js/contentScript.bundle.js:1:902
at chrome-extension://gccahjgcckaemgpliioopngfgdaceffo/js/contentScript.bundle.js:1:913
vendor-12543fec366da8e7c2cb59b3e19d826c.js:19441 Forest Admin :evergreen_tree: Start third-party services tracking.
vendor-12543fec366da8e7c2cb59b3e19d826c.js:19441 Disable custom header forest-environment-id, forest-project-id as it is not allowed by the client
vendor-12543fec366da8e7c2cb59b3e19d826c.js:19441 Drift has already been initialized.
(anonymous) @ vendor-12543fec366da8e7c2cb59b3e19d826c.js:19441
vendor-12543fec366da8e7c2cb59b3e19d826c.js:19441 Forest Admin :evergreen_tree: Start Drift tracking.
www.gravatar.com/avatar/29b83d7ba6e149df4b64d224ae7435f7?s=80&d=404:1 Failed to load resource: the server responded with a status of 404 ()
DevTools failed to load SourceMap: Could not parse content for https://app.forestadmin.com/assets/vendor-6225ff85d3e4dce967cd47b0433e57ed.map: Unexpected token < in JSON at position 0
DevTools failed to load SourceMap: Could not parse content for https://app.forestadmin.com/assets/client-4735d2ee63c28e123c0fa5de2e4f2c7a.map: Unexpected token < in JSON at position 0

@Guillaume_Laganier I’m sorry but so far I’m not able to reproduce the issue you’re facing.

The error logs you shared looks pretty unrelated from this undisplayed button issue.

In order to narrow the reasons that might have caused it could you please answer those questions:

  • Do you recall this button showing up and working properly recently? Has it disappear at once recently?
  • Have you made any changes on your backend recently? (adding a smart action, a smart field, upgrading forest-rails version)
  • Is that happening with all the actions from all your collections?

And lastly could you please share with me a screen cast of the following (with loom for example):

  • Open your ForestAdmin on a collection table
  • Open your browser and clean you logs
  • Toggle the edit layout mode while having the console open

I hope this will help me understand more about your issue and eventually find what’s going wrong with this reorder list :slight_smile:

Hello Valentin,

  • Yes, it disappeared last thursday night I guess. That’s the night we made several changes in our backend. We added 2 single tables inheritance : “Flight itineraries” and “Trains itineraries”, and added some new other tables in our production environment.
  • The smart actions order from existing tables is still the same since last thursday and the button to re order them is in fact still visible on some “old” tables (like Organizations or Teams you’ll see in the loom, but not Users, which is also an existing table since the beginning)
  • here is the loom : https://www.loom.com/share/48fc30b99e8043d6a24861bd8bbd9da1
    Thanks for your help !

cheers

@Guillaume_Laganier are you the only one experiencing this issue? Or are any other editor not able to see this button on edit mode?

Also could you try in another browser to see if you are stil unable to see the button?

Hello Valentin,

No, same issues for others here at Okarito :confused: I ask to the user remi@okarito.io, he has the same problem.

I tried on Safari, same problem too. I d’ont have the button in the flight itinerary table, but I do have it on the organizations table.

Cheers,

@Guillaume_Laganier,

Unfortunately I’m still unable to reproduce your issue. To narrow once again the potential issue, could you please tell me if this behavior also happens on other teams or just Operations and also if it happens on other environments as well (probably environments on which you made the same changes as in your production backend.

Thank you, we’ll do our best to help you get back this reorder button.

Also,

Could you confirm to me that even though the orange Actions button is not displayed in edit mode, it does exist when browsing and display all smart actions properly?

Hi @Guillaume_Laganier,

Really sorry that you’re facing this issue. But let’s find out what’s going on here! :raised_hands:

As @lamatt_v did, I’d be glad to know if you have the Actions button when not in edit mode and selecting one record, like this:

Meanwhile I’m trying to reproduce on my end.

Thanks!

Hello @Guillaume_Laganier,

We finally were able to reproduce your issue :tada:
And we deployed a fix.

Can you confirm it’s fixed on your side now?

Thanks!

2 Likes

Hello guys,

Yes ! It’s working again now, many thanks for your help !

Have a nice day,
Guillaume

1 Like

Great news!
Thanks for your feedback @Guillaume_Laganier :slight_smile: